summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-11-10 20:26:49 -0500
committerMike Frysinger <vapier@gentoo.org>2015-11-10 20:53:23 -0500
commit2347c6fe886c6b89d93ffac0faf375a613c372b1 (patch)
tree9ac1ed0abe7e86cbfe62a110a23675af21655134 /dev-java/groovy/groovy-2.4.5.ebuild
parentnet-libs/mbedtls: version bump to 2.1.3 (diff)
downloadgentoo-2347c6fe886c6b89d93ffac0faf375a613c372b1.tar.gz
gentoo-2347c6fe886c6b89d93ffac0faf375a613c372b1.tar.bz2
gentoo-2347c6fe886c6b89d93ffac0faf375a613c372b1.zip
avoid using ${var^} and ${var,} as they do not work in bash-3.2
Once these upgrade to EAPI=6, they can use these case modification features, so leave a reminder note in there.
Diffstat (limited to 'dev-java/groovy/groovy-2.4.5.ebuild')
-rw-r--r--dev-java/groovy/groovy-2.4.5.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-java/groovy/groovy-2.4.5.ebuild b/dev-java/groovy/groovy-2.4.5.ebuild
index 62183ff87c6d..d6d53f01fc77 100644
--- a/dev-java/groovy/groovy-2.4.5.ebuild
+++ b/dev-java/groovy/groovy-2.4.5.ebuild
@@ -7,7 +7,9 @@ JAVA_PKG_IUSE="doc source"
inherit java-pkg-2 java-pkg-simple versionator
-MY_PN="${PN^^}"
+# Switch to ^^ when we switch to EAPI=6.
+#MY_PN="${PN^^}"
+MY_PN="GROOVY"
MY_PV="$(replace_all_version_separators _ ${PV})"
MY_P="${MY_PN}_${MY_PV}"