summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-03-09 21:44:51 +0000
committerJames Le Cuirot <chewi@gentoo.org>2016-03-09 22:16:09 +0000
commitb6fee0b8522f30be3023e1dd109083c8d48a31b1 (patch)
tree27288a66a9de5137711180588ac464a597ff32b3 /dev-java/jboss-marshalling-river/jboss-marshalling-river-1.3.0.ebuild
parentdev-java/jboss-marshalling: Revision bump with minor improvements (diff)
downloadgentoo-b6fee0b8522f30be3023e1dd109083c8d48a31b1.tar.gz
gentoo-b6fee0b8522f30be3023e1dd109083c8d48a31b1.tar.bz2
gentoo-b6fee0b8522f30be3023e1dd109083c8d48a31b1.zip
dev-java/jboss-marshalling-river: New package for netty-codec's tests
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-java/jboss-marshalling-river/jboss-marshalling-river-1.3.0.ebuild')
-rw-r--r--dev-java/jboss-marshalling-river/jboss-marshalling-river-1.3.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-java/jboss-marshalling-river/jboss-marshalling-river-1.3.0.ebuild b/dev-java/jboss-marshalling-river/jboss-marshalling-river-1.3.0.ebuild
new file mode 100644
index 000000000000..aa43b9794caa
--- /dev/null
+++ b/dev-java/jboss-marshalling-river/jboss-marshalling-river-1.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="River protocol implementation for JBoss Marshalling"
+HOMEPAGE="http://jbossmarshalling.jboss.org/"
+SRC_URI="http://download.jboss.org/jbossmarshalling/${P}.CR9-sources.jar"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+CDEPEND="~dev-java/jboss-marshalling-${PV}:0"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.7"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.7
+ app-arch/unzip"
+
+JAVA_GENTOO_CLASSPATH="jboss-marshalling"
+
+src_compile() {
+ java-pkg-simple_src_compile
+ java-pkg_addres ${PN}.jar .
+}