summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-10-12 21:47:50 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-12 23:02:05 +0300
commitc81ef632826694b8cc944432d2319d7be471b6e0 (patch)
tree068c7f656a4c4f26dd7eb6904ef6b1a8a15228f7 /dev-java/joda-time
parentdev-java/snakeyaml: drop 1.30-r1 (diff)
downloadgentoo-c81ef632826694b8cc944432d2319d7be471b6e0.tar.gz
gentoo-c81ef632826694b8cc944432d2319d7be471b6e0.tar.bz2
gentoo-c81ef632826694b8cc944432d2319d7be471b6e0.zip
dev-java/joda-time: drop 2.10.14, 2.11.0
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/27758 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-java/joda-time')
-rw-r--r--dev-java/joda-time/Manifest2
-rw-r--r--dev-java/joda-time/joda-time-2.10.14.ebuild80
-rw-r--r--dev-java/joda-time/joda-time-2.11.0.ebuild95
3 files changed, 0 insertions, 177 deletions
diff --git a/dev-java/joda-time/Manifest b/dev-java/joda-time/Manifest
index f88a1d4f314c..9acad90f89bc 100644
--- a/dev-java/joda-time/Manifest
+++ b/dev-java/joda-time/Manifest
@@ -1,3 +1 @@
-DIST joda-time-2.10.14.tar.gz 1055876 BLAKE2B c70ad0724ad5e6d6f6a158ed05eb9711095cd353bf72a43a3edaa8ce36db1f92e0c18cd2e2b73c34e4126962d0ef97bf83844f9de924df8aadce7d38ffdb7975 SHA512 061c341c35f5187422fe402500384f5933c1eb0c77963f65b5295b8f9b479adf29f944269173d9a93e4a288c583777b21f085afe4c5da6c695f14801636f0fc1
-DIST joda-time-2.11.0.tar.gz 1055531 BLAKE2B 98b64e0419a1b7379d3467d012a1162afedb537048c86f8e9069ef5e21649dfe01d458a8e74ccb5dc052940b6edd2eba73ad86ae25bc20d3e62ec73a7a56a605 SHA512 357c8b3d1cc1cdd164cf2486a55ab9489db43c4243f140da5c21ee84bc3a801f51e2e2c2a257dbe2d2ce41bc33c676854136eddf3606ed7da69dcd3a10b2d010
DIST joda-time-2.11.2.tar.gz 1055885 BLAKE2B 52281dcb530734dd33d0c01b07c9fbc5e7afd507a97e6926f7ef442dc91907d999d126289bc609e6fabf6af4267e47e5a79452d462a3f0561c405e6cd7f5976f SHA512 ea43deea4ef751fc631c35589adec0c5d9d0a5c836c1a24ada5d994cb9310a55b5af69260afd2647516c64fc84b892a2e25fca4bb38e852982c40f7caa5858b3
diff --git a/dev-java/joda-time/joda-time-2.10.14.ebuild b/dev-java/joda-time/joda-time-2.10.14.ebuild
deleted file mode 100644
index c1c4f5c954e5..000000000000
--- a/dev-java/joda-time/joda-time-2.10.14.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# Skeleton command:
-# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/JodaOrg/joda-time/archive/v2.10.14.tar.gz --slot 0 --keywords "~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris" --ebuild joda-time-2.10.14.ebuild
-
-EAPI=8
-
-JAVA_PKG_IUSE="doc source test"
-MAVEN_ID="joda-time:joda-time:2.10.1r40"
-JAVA_TESTING_FRAMEWORKS="junit"
-
-inherit java-pkg-2 java-pkg-simple
-
-DESCRIPTION="Date and time library to replace JDK date handling"
-HOMEPAGE="https://www.joda.org/joda-time/"
-SRC_URI="https://github.com/JodaOrg/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
-
-# Common dependencies
-# POM: ${P}/pom.xml
-# org.joda:joda-convert:1.9.2 -> >=dev-java/joda-convert-2.2.1:0
-
-CP_DEPEND="
- >=dev-java/joda-convert-2.2.2-r2:0
-"
-
-DEPEND="
- >=virtual/jdk-1.8:*
- ${CP_DEPEND}
-"
-
-RDEPEND="
- >=virtual/jre-1.8:*
- ${CP_DEPEND}"
-
-S="${WORKDIR}/${P}"
-
-JAVA_SRC_DIR="src/main/java"
-JAVA_RESOURCE_DIRS="src/main/res"
-JAVA_AUTOMATIC_MODULE_NAME="org.joda.time"
-
-JAVA_TEST_GENTOO_CLASSPATH="junit"
-JAVA_TEST_SRC_DIR="src/test/java"
-JAVA_TEST_RESOURCE_DIRS="src/test/resources"
-
-src_prepare() {
- default
- # move .properties files to JAVA_RESOURCE_DIRS
- mkdir -p src/main/res
- cp -r src/main/{java/*,res} || die
- find src/main/res -type f ! -name '*.properties' -exec rm -rf {} + || die
-}
-
-src_compile() {
- java-pkg-simple_src_compile
-
- # Generate the missing "org/joda/time/tz/data/ZoneInfoMap"
- # Arguments from https://github.com/JodaOrg/joda-time/blob/v2.10.10/pom.xml#L413-L427
- "$(java-config -J)" \
- -cp ${PN}.jar \
- org.joda.time.tz.ZoneInfoCompiler \
- -src "${JAVA_SRC_DIR}/org/joda/time/tz/src" \
- -dst "src/main/res/org/joda/time/tz/data" \
- africa \
- antarctica \
- asia \
- australasia \
- europe \
- northamerica \
- southamerica \
- etcetera \
- backward
-
- # add org/joda/time/tz to the jar file
- jar -uf joda-time.jar -C src/main/res org/joda/time/tz/data || die
-}
diff --git a/dev-java/joda-time/joda-time-2.11.0.ebuild b/dev-java/joda-time/joda-time-2.11.0.ebuild
deleted file mode 100644
index f9c720bebe0a..000000000000
--- a/dev-java/joda-time/joda-time-2.11.0.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# Skeleton command:
-# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/JodaOrg/joda-time/archive/v2.11.0.tar.gz --slot 0 --keywords "~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris" --ebuild joda-time-2.11.0.ebuild
-
-EAPI=8
-
-JAVA_PKG_IUSE="doc source test"
-MAVEN_ID="joda-time:joda-time:2.11.0"
-JAVA_TESTING_FRAMEWORKS="junit"
-
-inherit edo java-pkg-2 java-pkg-simple
-
-DESCRIPTION="Date and time library to replace JDK date handling"
-HOMEPAGE="https://www.joda.org/joda-time/"
-SRC_URI="https://github.com/JodaOrg/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
-
-# Common dependencies
-# POM: pom.xml
-# org.joda:joda-convert:1.9.2 -> >=dev-java/joda-convert-2.2.2:0
-
-CP_DEPEND="dev-java/joda-convert:0"
-
-DEPEND=">=virtual/jdk-1.8:*
- ${CP_DEPEND}"
-
-RDEPEND=">=virtual/jre-1.8:*
- ${CP_DEPEND}"
-
-PATCHES=(
- # Enable tests for jdk-11 in
- # src/test/java/org/joda/time/TestDateTimeZone.java
- "${FILESDIR}/joda-time-2.11.0-test.patch"
-)
-
-DOCS=( NOTICE.txt README.md RELEASE-NOTES.txt )
-
-S="${WORKDIR}/${P}"
-
-JAVA_AUTOMATIC_MODULE_NAME="org.joda.time"
-JAVA_SRC_DIR="src/main/java"
-JAVA_RESOURCE_DIRS="src/main/res"
-
-JAVA_TEST_GENTOO_CLASSPATH="junit"
-JAVA_TEST_SRC_DIR="src/test/java"
-JAVA_TEST_RESOURCE_DIRS="src/test/resources"
-JAVA_TEST_RUN_ONLY="org.joda.time.TestAllPackages"
-
-src_prepare() {
- default
- # move .properties files to JAVA_RESOURCE_DIRS
- mkdir -p src/main/res
- cp -r src/main/{java/*,res} || die
- find src/main/res -type f ! -name '*.properties' -exec rm -rf {} + || die
-}
-
-src_compile() {
- java-pkg-simple_src_compile
-
- # Generate the missing "org/joda/time/tz/data/ZoneInfoMap"
- # Arguments from https://github.com/JodaOrg/joda-time/blob/v2.10.10/pom.xml#L413-L427
- edo "$(java-config -J)" \
- -cp ${PN}.jar \
- org.joda.time.tz.ZoneInfoCompiler \
- -src "${JAVA_SRC_DIR}/org/joda/time/tz/src" \
- -dst "${P}/src/main/resources/org/joda/time/tz/data" \
- africa \
- antarctica \
- asia \
- australasia \
- europe \
- northamerica \
- southamerica \
- etcetera \
- backward
-
- java-pkg_addres ${PN}.jar "${P}"/src/main/resources
-}
-
-src_test() {
- # There are test failures in
- # src/test/java/org/joda/time/TestDateTimeZone.java
- # with jdk higher than 11
- local vm_version="$(java-config -g PROVIDES_VERSION)"
- if ver_test "${vm_version}" -le 11 ; then
- java-pkg-simple_src_test
- else
- einfo "Tests restricted to <=jdk-11"
- fi
-}