summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jtreemap
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jtreemap')
-rw-r--r--dev-java/jtreemap/Manifest1
-rw-r--r--dev-java/jtreemap/files/jtreemap-1.1.0-build.xml.patch30
-rw-r--r--dev-java/jtreemap/jtreemap-1.1.0.ebuild35
-rw-r--r--dev-java/jtreemap/metadata.xml11
4 files changed, 77 insertions, 0 deletions
diff --git a/dev-java/jtreemap/Manifest b/dev-java/jtreemap/Manifest
new file mode 100644
index 000000000000..785749b29535
--- /dev/null
+++ b/dev-java/jtreemap/Manifest
@@ -0,0 +1 @@
+DIST jtreemap-1.1.0-src.zip 7358161 SHA256 c6e27ec233e0da4e9ca7dc8b9a07ad60e99aad4cf9973c0fc4f37d0e58a158a3 SHA512 61c6b5e22cc839d6cfe8368bbd51db94b3667c8f4064645c3d70f5e6c93b029dd495b64b602570f59559dd99723516a197dcd1d915799411dc7f7c516bfce84c WHIRLPOOL e82944d0317b7ad3848552ebfe474d1bd8b58d13ce59a36f7339c15b8d23ab1ebade829072b79b46606f340c4b664038d1156732d57791cbd191c51d136d7ef2
diff --git a/dev-java/jtreemap/files/jtreemap-1.1.0-build.xml.patch b/dev-java/jtreemap/files/jtreemap-1.1.0-build.xml.patch
new file mode 100644
index 000000000000..fe9769c207fe
--- /dev/null
+++ b/dev-java/jtreemap/files/jtreemap-1.1.0-build.xml.patch
@@ -0,0 +1,30 @@
+diff -Nur jtreemap-site-1.1.0/JTreeMap/build.xml jtreemap-site-1.1.0_patched/JTreeMap/build.xml
+--- jtreemap-site-1.1.0/JTreeMap/build.xml 2007-04-29 11:46:46.000000000 +0300
++++ jtreemap-site-1.1.0_patched/JTreeMap/build.xml 2008-09-27 19:45:03.000000000 +0300
+@@ -33,6 +33,10 @@
+ <include name="**/*.class" />
+ <include name="**/*.png" />
+ <include name="**/*.gif" />
++ </fileset>
++ <fileset dir="${java.dir}/main/java">
++ <include name="**/*.dtd" />
++ <include name="**/*.png" />
+ </fileset>
+ <manifest>
+ <attribute name="Main-Class" value="net.sf.jtreemap.swing.example.JTreeMapExample" />
+@@ -60,7 +64,7 @@
+ </target>
+
+ <target name="javadoc">
+- <javadoc packagenames="net.sf.jtreemap.swing.*,net.sf.jtreemap.swing.example.*" sourcepath="src" defaultexcludes="yes" destdir="doc" author="true" version="true" use="true" windowtitle="JTreeMap">
++ <javadoc packagenames="net.sf.jtreemap.swing.*,net.sf.jtreemap.swing.example.*" sourcepath="src/main/java" defaultexcludes="yes" destdir="doc" author="true" version="true" use="true" windowtitle="JTreeMap">
+ <doctitle>
+ <![CDATA[<h1>JTreeMap</h1>]]></doctitle>
+ <tag name="todo" scope="all" description="To do:" />
+@@ -78,4 +82,4 @@
+ </zip>
+ </target>
+
+-</project>
+\ Dosya sonunda yenisatır yok.
++</project>
diff --git a/dev-java/jtreemap/jtreemap-1.1.0.ebuild b/dev-java/jtreemap/jtreemap-1.1.0.ebuild
new file mode 100644
index 000000000000..dda67745dc74
--- /dev/null
+++ b/dev-java/jtreemap/jtreemap-1.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Java, open-source library for treemapping"
+HOMEPAGE="http://jtreemap.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.zip"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip"
+
+S="${WORKDIR}/${PN}-site-${PV}/JTreeMap"
+EANT_BUILD_TARGET="buildJar"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}-build.xml.patch
+ einfo "Removing bundled jars."
+ find . -name "*.jar" -print -delete
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+ use doc && java-pkg_dojavadoc doc
+ java-pkg_dolauncher ${PN}-demo --main net.sf.jtreemap.swing.example.JTreeMapExample
+ use source && java-pkg_dosrc src/main/java/net
+}
diff --git a/dev-java/jtreemap/metadata.xml b/dev-java/jtreemap/metadata.xml
new file mode 100644
index 000000000000..091965f6213c
--- /dev/null
+++ b/dev-java/jtreemap/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <maintainer>
+ <email>java@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">jtreemap</remote-id>
+ </upstream>
+</pkgmetadata>