summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-10-17 18:53:05 -0500
committerAustin English <wizardedit@gentoo.org>2016-10-17 19:01:29 -0500
commitd419b273959e182ab438e48203fe9d81808a596d (patch)
tree98859978d653fa0219d3e84ded3e4633e3f52143 /dev-java/okio/okio-1.11.0.ebuild
parentdev-java/jmh-core: initial ebuild (diff)
downloadgentoo-d419b273959e182ab438e48203fe9d81808a596d.tar.gz
gentoo-d419b273959e182ab438e48203fe9d81808a596d.tar.bz2
gentoo-d419b273959e182ab438e48203fe9d81808a596d.zip
dev-java/okio: initial ebuild
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-java/okio/okio-1.11.0.ebuild')
-rw-r--r--dev-java/okio/okio-1.11.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-java/okio/okio-1.11.0.ebuild b/dev-java/okio/okio-1.11.0.ebuild
new file mode 100644
index 000000000000..cca6f42c8189
--- /dev/null
+++ b/dev-java/okio/okio-1.11.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_P="${PN}-parent-${PV}"
+
+DESCRIPTION="A modern I/O API for Java"
+HOMEPAGE="https://github.com/square/okio"
+SRC_URI="https://github.com/square/${PN}/archive/${MY_P}.zip -> ${P}.zip"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=virtual/jre-1.7"
+
+CDEPEND="
+ source? ( app-arch/zip )
+ dev-java/jmh-core:0
+ dev-java/junit:4"
+
+DEPEND=">=virtual/jdk-1.7
+ ${CDEPEND}"
+
+RDEPEND=">=virtual/jre-1.7
+ ${CDEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_P}"
+
+JAVA_GENTOO_CLASSPATH="jmh-core,junit-4"
+
+src_prepare(){
+ epatch "${FILESDIR}/okio-remove-maven-animal-jre.patch"
+}