summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/wsdl4j/wsdl4j-1.6.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/wsdl4j/wsdl4j-1.6.2.ebuild')
-rw-r--r--dev-java/wsdl4j/wsdl4j-1.6.2.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-java/wsdl4j/wsdl4j-1.6.2.ebuild b/dev-java/wsdl4j/wsdl4j-1.6.2.ebuild
new file mode 100644
index 000000000000..5de603e1a8c2
--- /dev/null
+++ b/dev-java/wsdl4j/wsdl4j-1.6.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit versionator java-pkg-2 java-ant-2
+
+DESCRIPTION="Web Services Description Language for Java Toolkit (WSDL4J)"
+HOMEPAGE="http://wsdl4j.sourceforge.net"
+
+TCK="jwsdltck"
+TCK_V="1.2"
+
+SRC_URI="mirror://sourceforge/${PN}/${PN}-src-${PV}.zip
+ test? ( mirror://sourceforge/${TCK}/${TCK}-bin-${TCK_V}.zip )"
+
+LICENSE="CPL-1.0"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86 ~x86-fbsd"
+
+DEPEND=">=virtual/jdk-1.4
+ test? ( =dev-java/junit-3.8* )
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}/${PN}-$(replace_all_version_separators _)"
+TCK_S="${WORKDIR}/${TCK}-$(replace_all_version_separators _ ${TCK_V})"
+
+src_unpack() {
+ unpack ${A}
+ if use test; then
+ rm -v "${TCK_S}"/lib/*.jar || die
+ epatch "${FILESDIR}/1.6.2-tests-sandbox.patch"
+ fi
+}
+
+EANT_BUILD_TARGET="compile"
+EANT_DOC_TARGET="javadocs"
+
+src_test() {
+ ln -s "${TCK_S}" test
+ cd "${TCK_S}"
+ java-ant_rewrite-classpath
+ local junit="$(java-pkg_getjars junit)"
+ eant -Dbuild.lib="${S}/test/lib" compile \
+ -Dgentoo.classpath="${S}/build/lib/${PN}.jar:${junit}"
+ cd "${S}"
+ mkdir "${T}/lib"
+ ANT_TASKS="ant-junit" eant test -Dtemp.dir="${T}"
+}
+
+src_install() {
+ java-pkg_dojar build/lib/*.jar
+
+ use doc && java-pkg_dojavadoc build/javadocs/
+ use source && java-pkg_dosrc src/*
+}