summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2019-08-06 17:50:13 +1200
committerKent Fredric <kentnl@gentoo.org>2019-08-06 17:50:13 +1200
commit50ca4579669dac5459ee428970e9f358ae41c498 (patch)
tree72b2b503171794d289903dc6a70f207908d0778d /dev-java
parentdev-lang/moarvm: Fix minimum libuv re bug #652214 (diff)
downloadgentoo-50ca4579669dac5459ee428970e9f358ae41c498.tar.gz
gentoo-50ca4579669dac5459ee428970e9f358ae41c498.tar.bz2
gentoo-50ca4579669dac5459ee428970e9f358ae41c498.zip
dev-java/boot-bin: Add missing shebang re bug #682984
Add a shebang to the boot bootup script so it works for users who have a native shell other than bash. -r1 bump necessary as if you already had it installed, it was possibly broken. Closes: https://bugs.gentoo.org/682984 Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/boot-bin/boot-bin-2.7.1-r1.ebuild (renamed from dev-java/boot-bin/boot-bin-2.7.1.ebuild)2
-rw-r--r--dev-java/boot-bin/files/boot1
2 files changed, 2 insertions, 1 deletions
diff --git a/dev-java/boot-bin/boot-bin-2.7.1.ebuild b/dev-java/boot-bin/boot-bin-2.7.1-r1.ebuild
index 8e700cc2e66e..53777ba1edb0 100644
--- a/dev-java/boot-bin/boot-bin-2.7.1.ebuild
+++ b/dev-java/boot-bin/boot-bin-2.7.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
diff --git a/dev-java/boot-bin/files/boot b/dev-java/boot-bin/files/boot
index acd8e404c28c..8d53ebd338a8 100644
--- a/dev-java/boot-bin/files/boot
+++ b/dev-java/boot-bin/files/boot
@@ -1,3 +1,4 @@
+#!/bin/bash
source @@JAVA_PKG_SHAREPATH@@/package.env
jarpath="@@JAVA_PKG_JARDEST@@/@@PN@@.jar"
declare -a "options=($BOOT_JVM_OPTIONS)"