summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-09-30 18:48:38 +0200
committerAlfredo Tupone <tupone@gentoo.org>2022-09-30 18:50:52 +0200
commit65d2fdfea526104ef7734f86ba72d7d72e1462e1 (patch)
treebf8bdf3dd0fc1aef3ad0ba675f0a1703b2ca2066 /dev-lang/gnat-gpl
parentwww-plugins/chrome-binary-plugins: automated update (108.0.5327.0_alpha) (diff)
downloadgentoo-65d2fdfea526104ef7734f86ba72d7d72e1462e1.tar.gz
gentoo-65d2fdfea526104ef7734f86ba72d7d72e1462e1.tar.bz2
gentoo-65d2fdfea526104ef7734f86ba72d7d72e1462e1.zip
dev-lang/gnat-gpl: add backported gcc-patches
Closes: https://bugs.gentoo.org/868789 Closes: https://bugs.gentoo.org/867196 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-lang/gnat-gpl')
-rw-r--r--dev-lang/gnat-gpl/Manifest1
-rw-r--r--dev-lang/gnat-gpl/gnat-gpl-2021-r4.ebuild (renamed from dev-lang/gnat-gpl/gnat-gpl-2021-r3.ebuild)23
2 files changed, 11 insertions, 13 deletions
diff --git a/dev-lang/gnat-gpl/Manifest b/dev-lang/gnat-gpl/Manifest
index 6671d7a186bf..b6481237bd30 100644
--- a/dev-lang/gnat-gpl/Manifest
+++ b/dev-lang/gnat-gpl/Manifest
@@ -1,5 +1,6 @@
DIST gcc-10-2021-20210519-19A74-src.tar.gz 109157702 BLAKE2B 8ec307e4fde35c8726bc7b9702717329695bad928d5222a7bb691cce47500de31a60bcfcbb925129a57cb81d3d7ea92e60599aa7383d5358e63cc087b0482550 SHA512 2e2cc0ec9a3a82816a5d399d2db261c356e106b82a44efd54a1ac882b96549ab8de79c69858127c4397de6e9e9463ce6fb9994fc2e426e7d3d2f98d5efa2edb6
DIST gcc-10.3.0-patches-3.tar.bz2 18935 BLAKE2B 13eaf1e055b5b63069aed1575ed93f6bc822b5e3f2181ddfc88f4e7ff801f58997cd131b2efd79b90469b1f861db994feb2adcaecacf165442078f76e233fd9a SHA512 c3d6a6f32863cc0ff7c877314ff0c00a892e473f64d16b82d46b4a77aa97c3e7a575492d27f0d423acb2621c86c9a49bca0e26e45bda9e697495444fcac85084
+DIST gcc-10.3.0-patches-4.tar.xz 18460 BLAKE2B 7c4b91c3beebc5fd91c0fdbeec6512c141bd78759a02aa7fff32dd30025ef41db1d57280e50db575f46cc0061a480ced9259410e9875b1dc0048886df469c4c9 SHA512 3befbcdec84e583966aad37d1a08c1863f39eb877296c5991348db9d37cc8359197f23cb3b8fa1b0f4d01497dfd2ebaa393e1a459267c19a0976fb535e463ec8
DIST gcc-9-2020-20200429-19AA7-src.tar.gz 101030094 BLAKE2B 843d7a92f206a08aa6c0fb41b8b93db494eee26c15872b8d8547685c1013559856cd83c5a4139d8ba68aa6737c0270502fd5547664b458cb8fd023f5ce9601e8 SHA512 2eaf999f4ef7f0216b7bab9963ce1cb9dd4be4d4645415183a0e0706ce0f0f119a5437c482d60db16ea152ebcb36186fc7900ec196fc7b8022d4d9cea2e5a631
DIST gcc-9.3.0-patches-5.tar.bz2 18336 BLAKE2B 8aefb94bfec041da69efdd751fe9df58cc2352e66afe7ec2090da698912e31de8a82ef588e393929f50dbc6d5967bb015f8e807f868ec19c7cf9813495fa4687 SHA512 0eedc2a33b7fa1a846a30055dcaf38ea9882d5c7b3d8a7d9145fe768d778747413b7822fc625135fa010e749fbbda51f7460e03c989dee8551c50b798a9d1aba
DIST gcc-interface-10-2021-20210519-19A75-src.tar.gz 359085 BLAKE2B 75f941a7635f2880cc0192acb49d8e7f567baca7530fb981be14dc6cb1bf46fda0e3c043c8703cdbeeb242b548894e0bc6787adfff0f27198354d150e6e36386 SHA512 0251a93d20c59cc4705963438880fe265e2e0bb94a35b7ddaaf03e9efae60e044e585a2204d0773a46f17b3b774e4d0c73adf852f5d06ba17373d26ed580ca8d
diff --git a/dev-lang/gnat-gpl/gnat-gpl-2021-r3.ebuild b/dev-lang/gnat-gpl/gnat-gpl-2021-r4.ebuild
index 3122d8366ba2..1d550e0fd45b 100644
--- a/dev-lang/gnat-gpl/gnat-gpl-2021-r3.ebuild
+++ b/dev-lang/gnat-gpl/gnat-gpl-2021-r4.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PATCH_GCC_VER=10.3.0
-PATCH_VER="3"
+PATCH_VER="4"
TOOLCHAIN_GCC_PV=10.3.1
@@ -50,17 +50,6 @@ BDEPEND=sys-devel/binutils
S="${WORKDIR}"/${MYP}
-src_unpack() {
- if ! use bootstrap && [[ -z "$(type ${GNATMAKE} 2>/dev/null)" ]] ; then
- eerror "You need a gcc compiler that provides the Ada Compiler:"
- eerror "1) use gcc-config to select the right compiler or"
- eerror "2) set the bootstrap use flag"
- die "ada compiler not available"
- fi
-
- toolchain_src_unpack
-}
-
src_prepare() {
if use amd64; then
BTSTRP=${BTSTRP_AMD64}
@@ -81,6 +70,14 @@ src_prepare() {
if [[ ${gnatpath} != "." ]] ; then
GNATMAKE="${gnatpath}/${GNATMAKE}"
fi
+
+ if ! use bootstrap && [[ -z "$(type ${GNATMAKE} 2>/dev/null)" ]] ; then
+ eerror "You need a gcc compiler that provides the Ada Compiler:"
+ eerror "1) use gcc-config to select the right compiler or"
+ eerror "2) set the bootstrap use flag"
+ die "ada compiler not available"
+ fi
+
if use bootstrap; then
rm "${WORKDIR}"/${BTSTRP}/libexec/gcc/x86_64-pc-linux-gnu/4.7.4/ld \
|| die