summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-31 11:02:23 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-31 11:02:23 +0100
commit7daa625323da23a6972311c35ffeb0cd792e1a9b (patch)
treee2665f59784354b33daee291f99f624dd1755f0c /dev-lang/ispc
parentdev-lang/ispc: Add myself as maintainer (diff)
downloadgentoo-7daa625323da23a6972311c35ffeb0cd792e1a9b.tar.gz
gentoo-7daa625323da23a6972311c35ffeb0cd792e1a9b.tar.bz2
gentoo-7daa625323da23a6972311c35ffeb0cd792e1a9b.zip
dev-lang/ispc: Restore the hack to disable multilib
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang/ispc')
-rw-r--r--dev-lang/ispc/ispc-1.22.0.ebuild12
1 files changed, 12 insertions, 0 deletions
diff --git a/dev-lang/ispc/ispc-1.22.0.ebuild b/dev-lang/ispc/ispc-1.22.0.ebuild
index 60ee837fac5f..fb2b1f2ba1d3 100644
--- a/dev-lang/ispc/ispc-1.22.0.ebuild
+++ b/dev-lang/ispc/ispc-1.22.0.ebuild
@@ -41,6 +41,18 @@ pkg_setup() {
python-any-r1_pkg_setup
}
+src_prepare() {
+ if use amd64; then
+ # On amd64 systems, build system enables x86/i686 build too.
+ # This ebuild doesn't even have multilib support, nor need it.
+ # https://bugs.gentoo.org/730062
+ ewarn "Removing auto-x86 build on amd64"
+ sed -i -e 's:set(target_arch "i686"):return():' cmake/GenerateBuiltins.cmake || die
+ fi
+
+ cmake_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DARM_ENABLED=$(usex arm)