summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-09-06 17:50:28 +0200
committerDavid Seifert <soap@gentoo.org>2022-09-06 17:50:28 +0200
commita1929e7f66f0e162ef377c37deaa0057249fcd69 (patch)
tree13a2eed1455d49748748cb231f2077c307a00e1f /dev-lang/lua/lua-5.1.5-r200.ebuild
parentnet-p2p/arti: drop 0.5.0 (diff)
downloadgentoo-a1929e7f66f0e162ef377c37deaa0057249fcd69.tar.gz
gentoo-a1929e7f66f0e162ef377c37deaa0057249fcd69.tar.bz2
gentoo-a1929e7f66f0e162ef377c37deaa0057249fcd69.zip
dev-lang/lua: remove wrong 5.1.6
* This upstream release never existed and I have no idea what led me to this version string. Closes: https://bugs.gentoo.org/868753 Closes: https://bugs.gentoo.org/868756 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-lang/lua/lua-5.1.5-r200.ebuild')
-rw-r--r--dev-lang/lua/lua-5.1.5-r200.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-lang/lua/lua-5.1.5-r200.ebuild b/dev-lang/lua/lua-5.1.5-r200.ebuild
new file mode 100644
index 000000000000..663b24b5579f
--- /dev/null
+++ b/dev-lang/lua/lua-5.1.5-r200.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="A powerful light-weight programming language designed for extending applications"
+HOMEPAGE="https://www.lua.org/"
+# tarballs produced from ${PV} branches in https://gitweb.gentoo.org/proj/lua-patches.git
+SRC_URI="https://dev.gentoo.org/~soap/distfiles/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="5.1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+deprecated readline"
+
+DEPEND="
+ >=app-eselect/eselect-lua-3
+ readline? ( sys-libs/readline:= )
+ !dev-lang/lua:0"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${SLOT} )
+
+src_prepare() {
+ ! use deprecated && PATCHES+=(
+ "${FILESDIR}"/${PN}-5.1.4-test.patch
+ )
+ default
+}
+
+src_configure() {
+ econf \
+ $(use_enable deprecated) \
+ $(use_with readline)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ eselect lua set --if-unset "${PN}${SLOT}"
+
+ optfeature "Lua support for Emacs" app-emacs/lua-mode
+}