summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-08-28 19:56:53 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-28 19:57:13 +0100
commitced0d3814de31f76c0d8a56bded0f1ab28bceb1c (patch)
tree8369bb2e53b015b92d3406a85ae15197e5557014 /dev-lang/nasm/nasm-2.15.05.ebuild
parentdev-perl/File-Flat: bump to version 1.70.0 (diff)
downloadgentoo-ced0d3814de31f76c0d8a56bded0f1ab28bceb1c.tar.gz
gentoo-ced0d3814de31f76c0d8a56bded0f1ab28bceb1c.tar.bz2
gentoo-ced0d3814de31f76c0d8a56bded0f1ab28bceb1c.zip
dev-lang/nasm: bump up to 2.15.05
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-lang/nasm/nasm-2.15.05.ebuild')
-rw-r--r--dev-lang/nasm/nasm-2.15.05.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-lang/nasm/nasm-2.15.05.ebuild b/dev-lang/nasm/nasm-2.15.05.ebuild
new file mode 100644
index 000000000000..50972bc3e57f
--- /dev/null
+++ b/dev-lang/nasm/nasm-2.15.05.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="groovy little assembler"
+HOMEPAGE="https://www.nasm.us/"
+SRC_URI="https://www.nasm.us/pub/nasm/releasebuilds/${PV/_}/${P/_}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ia64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND=""
+# [fonts note] doc/psfonts.ph defines ordered list of font preference.
+# Currently 'media-fonts/source-pro' is most preferred and is able to
+# satisfy all 6 font flavours: tilt, chapter, head, etc.
+BDEPEND="
+ dev-lang/perl
+ doc? (
+ app-text/ghostscript-gpl
+ dev-perl/Font-TTF
+ dev-perl/Sort-Versions
+ media-fonts/source-pro
+ virtual/perl-File-Spec
+ )
+"
+
+S=${WORKDIR}/${P/_}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.15-bsd-cp-doc.patch
+)
+
+src_compile() {
+ default
+ use doc && emake doc
+}
+
+src_install() {
+ default
+ emake DESTDIR="${D}" install_rdf $(usex doc install_doc '')
+}