summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-04-21 08:36:10 +1200
committerKent Fredric <kentnl@gentoo.org>2017-04-21 08:37:10 +1200
commit31be046e359c79da7d29d5905d62fc79294ec6a3 (patch)
treef9a5eeac3acff9a0219282b22c843bceb663e982 /dev-lang/perl/perl-5.26.9999.ebuild
parentYou touch it, you own it (diff)
downloadgentoo-31be046e359c79da7d29d5905d62fc79294ec6a3.tar.gz
gentoo-31be046e359c79da7d29d5905d62fc79294ec6a3.tar.bz2
gentoo-31be046e359c79da7d29d5905d62fc79294ec6a3.zip
dev-lang/perl: Update 5.26.9999 to 5.25.12 internally
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-lang/perl/perl-5.26.9999.ebuild')
-rw-r--r--dev-lang/perl/perl-5.26.9999.ebuild22
1 files changed, 12 insertions, 10 deletions
diff --git a/dev-lang/perl/perl-5.26.9999.ebuild b/dev-lang/perl/perl-5.26.9999.ebuild
index 62d914d8c9a8..cca25d8713d8 100644
--- a/dev-lang/perl/perl-5.26.9999.ebuild
+++ b/dev-lang/perl/perl-5.26.9999.ebuild
@@ -15,19 +15,21 @@ if [[ "${PV##*.}" == "9999" ]]; then
# Include more versions for blead releases
# for circular reasons
# Greatest first, don't include yourself
- PERL_BIN_OLDVERSEN=""
- PERL_OLDVERSEN="5.24.2 5.24.1 5.24.0 5.22.3 5.22.2 5.22.1 5.22.0"
- DIST_VERSION=5.25.11
+ PERL_BIN_OLDVERSEN="5.25.11"
+ PERL_OLDVERSEN="5.25.11 5.24.2 5.24.1 5.24.0 5.22.3 5.22.2 5.22.1 5.22.0"
+ DIST_VERSION=5.25.12
SHORT_PV="${DIST_VERSION%.*}"
MY_P="perl-${DIST_VERSION/_rc/-RC}"
+ PATCH_BASE="perl-5.25.11-patches-${PATCH_VER}"
MY_PV="${DIST_VERSION%_rc*}"
else
- PERL_BIN_OLDVERSEN=""
+ PERL_BIN_OLDVERSEN="5.25.11"
# Compat reasons
- PERL_OLDVERSEN=""
+ PERL_OLDVERSEN="5.25.11"
# First 2 digits only
SHORT_PV="${PV%.*}"
MY_P="perl-${PV/_rc/-RC}"
+ PATCH_BASE="${MY_P}-patches-${PATCH_VER}"
MY_PV="${PV%_rc*}"
fi
@@ -36,9 +38,9 @@ DESCRIPTION="Larry Wall's Practical Extraction and Report Language"
SRC_URI="
mirror://cpan/src/5.0/${MY_P}.tar.xz
mirror://cpan/authors/id/${DIST_AUTHOR:0:1}/${DIST_AUTHOR:0:2}/${DIST_AUTHOR}/${MY_P}.tar.xz
- https://github.com/gentoo-perl/perl-patchset/releases/download/${MY_P}-patches-${PATCH_VER}/${MY_P}-patches-${PATCH_VER}.tar.xz
- mirror://gentoo/${MY_P}-patches-${PATCH_VER}.tar.xz
- https://dev.gentoo.org/~kentnl/distfiles/${MY_P}-patches-${PATCH_VER}.tar.xz
+ https://github.com/gentoo-perl/perl-patchset/releases/download/${PATCH_BASE}/${PATCH_BASE}.tar.xz
+ mirror://gentoo/${PATCH_BASE}.tar.xz
+ https://dev.gentoo.org/~kentnl/distfiles/${PATCH_BASE}.tar.xz
https://github.com/arsv/perl-cross/releases/download/${CROSS_VER}/perl-cross-${CROSS_VER}.tar.gz
"
HOMEPAGE="http://www.perl.org/"
@@ -304,7 +306,7 @@ src_prepare_dynamic() {
src_prepare() {
local patch
EPATCH_OPTS+=" -p1"
- einfo "Applying patches from ${MY_P}-${PATCH_VER} ..."
+ einfo "Applying patches from ${PATCH_BASE} ..."
while read patch ; do
EPATCH_SINGLE_MSG=" ${patch} ..."
epatch "${WORKDIR}"/patches/${patch}
@@ -396,7 +398,7 @@ src_configure() {
if [[ -n ${PERL_OLDVERSEN} ]] ; then
local inclist=$(
for v in ${PERL_OLDVERSEN}; do
- has "${v}" "${PERL_BIN_OLDVERSEN}" && echo -n "${v}/${myarch}${mythreading} ";
+ has "${v}" ${PERL_BIN_OLDVERSEN} && echo -n "${v}/${myarch}${mythreading} ";
echo -n "${v} ";
done )
myconf -Dinc_version_list="${inclist}"