summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYiFei Zhu <zhuyifei1999@gmail.com>2023-05-30 13:44:38 -0700
committerSam James <sam@gentoo.org>2023-05-31 04:33:57 +0100
commit2f351e0037e036d3922956c521005d00e24a66b6 (patch)
tree205b7e6878b5c39ca516c424a461ba7bdbba939c /dev-lang/python
parentnet-libs/libssh2: conditionally set test options (diff)
downloadgentoo-2f351e0037e036d3922956c521005d00e24a66b6.tar.gz
gentoo-2f351e0037e036d3922956c521005d00e24a66b6.tar.bz2
gentoo-2f351e0037e036d3922956c521005d00e24a66b6.zip
dev-lang/python: Fix configure in Prefix for 3.12
Upstream removed setup.py in 3.12 [1]. Attempting to use hprefixify on this now non-existent file causes: >>> Configuring source in /prefix/var/tmp/portage/dev-lang/python-3.12.0_beta1_p1/work/Python-3.12.0b1 ... * Adjusting to prefix /prefix * ERROR: dev-lang/python-3.12.0_beta1_p1::gentoo failed (configure phase): * setup.py does not exist I also removed inherit on prefix.eclass now that it is unused. Tested this patch on an aarch64 prefix and it created no QA warnings. [1] https://github.com/python/cpython/commit/81dca70d704d0834d8c30580e648a973250b2973 Signed-off-by: YiFei Zhu <zhuyifei1999@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31232 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/python-3.12.0_beta1.ebuild3
-rw-r--r--dev-lang/python/python-3.12.0_beta1_p1.ebuild3
2 files changed, 2 insertions, 4 deletions
diff --git a/dev-lang/python/python-3.12.0_beta1.ebuild b/dev-lang/python/python-3.12.0_beta1.ebuild
index 14f92570e8f9..e79715cc645a 100644
--- a/dev-lang/python/python-3.12.0_beta1.ebuild
+++ b/dev-lang/python/python-3.12.0_beta1.ebuild
@@ -5,7 +5,7 @@ EAPI="7"
WANT_LIBTOOL="none"
inherit autotools check-reqs flag-o-matic multiprocessing pax-utils
-inherit prefix python-utils-r1 toolchain-funcs verify-sig
+inherit python-utils-r1 toolchain-funcs verify-sig
MY_PV=${PV/_beta/b}
MY_P="Python-${MY_PV%_p*}"
@@ -301,7 +301,6 @@ src_configure() {
append-cppflags -I"${ESYSROOT}"/usr/include/ncursesw
fi
- hprefixify setup.py
econf "${myeconfargs[@]}"
if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
diff --git a/dev-lang/python/python-3.12.0_beta1_p1.ebuild b/dev-lang/python/python-3.12.0_beta1_p1.ebuild
index 14f92570e8f9..e79715cc645a 100644
--- a/dev-lang/python/python-3.12.0_beta1_p1.ebuild
+++ b/dev-lang/python/python-3.12.0_beta1_p1.ebuild
@@ -5,7 +5,7 @@ EAPI="7"
WANT_LIBTOOL="none"
inherit autotools check-reqs flag-o-matic multiprocessing pax-utils
-inherit prefix python-utils-r1 toolchain-funcs verify-sig
+inherit python-utils-r1 toolchain-funcs verify-sig
MY_PV=${PV/_beta/b}
MY_P="Python-${MY_PV%_p*}"
@@ -301,7 +301,6 @@ src_configure() {
append-cppflags -I"${ESYSROOT}"/usr/include/ncursesw
fi
- hprefixify setup.py
econf "${myeconfargs[@]}"
if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then