summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-01-27 11:06:38 -0500
committerMike Gilbert <floppym@gentoo.org>2021-01-27 11:06:38 -0500
commit56566e139e376bd02c170be73a56ba933766979a (patch)
treeaf8ab17dfa9f2f71532b91ea963eceddac56c357 /dev-lang/python
parentdev-libs/libbytesize: Bump to version 2.5 (diff)
downloadgentoo-56566e139e376bd02c170be73a56ba933766979a.tar.gz
gentoo-56566e139e376bd02c170be73a56ba933766979a.tar.bz2
gentoo-56566e139e376bd02c170be73a56ba933766979a.zip
dev-lang/python: Readd check for failed semaphore checks in 3.10
Bug: https://bugs.gentoo.org/496328 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/python-3.10.0_alpha4.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-lang/python/python-3.10.0_alpha4.ebuild b/dev-lang/python/python-3.10.0_alpha4.ebuild
index a07c3376effd..a68e95cd0c12 100644
--- a/dev-lang/python/python-3.10.0_alpha4.ebuild
+++ b/dev-lang/python/python-3.10.0_alpha4.ebuild
@@ -186,6 +186,12 @@ src_configure() {
)
OPT="" econf "${myeconfargs[@]}"
+
+ if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
+ eerror "configure has detected that the sem_open function is broken."
+ eerror "Please ensure that /dev/shm is mounted as a tmpfs with mode 1777."
+ die "Broken sem_open function (bug 496328)"
+ fi
}
src_compile() {