summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-25 13:34:24 +0100
committerSam James <sam@gentoo.org>2021-10-25 13:35:11 +0100
commit717eba5b5cfb78b1438c348882b34c88b3dc173a (patch)
treed603241371a01b2c5920e7528f70026b56bb586b /dev-lang/tcc/tcc-9999.ebuild
parentapp-misc/physlock: Add patch to set PAM_TTY (diff)
downloadgentoo-717eba5b5cfb78b1438c348882b34c88b3dc173a.tar.gz
gentoo-717eba5b5cfb78b1438c348882b34c88b3dc173a.tar.bz2
gentoo-717eba5b5cfb78b1438c348882b34c88b3dc173a.zip
dev-lang/tcc: add 0.9.27_p20211022 (glibc-2.34, security fixes)
Upstream development seems to just be rolling now too. Closes: https://bugs.gentoo.org/806511 Bug: https://bugs.gentoo.org/737092 Bug: https://bugs.gentoo.org/715428 Bug: https://bugs.gentoo.org/765652 Bug: https://bugs.gentoo.org/687114 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/tcc/tcc-9999.ebuild')
-rw-r--r--dev-lang/tcc/tcc-9999.ebuild43
1 files changed, 25 insertions, 18 deletions
diff --git a/dev-lang/tcc/tcc-9999.ebuild b/dev-lang/tcc/tcc-9999.ebuild
index 5aa530ef3af5..f53743b5e6b9 100644
--- a/dev-lang/tcc/tcc-9999.ebuild
+++ b/dev-lang/tcc/tcc-9999.ebuild
@@ -1,34 +1,42 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=8
+inherit toolchain-funcs
+
+MY_COMMIT="16456168430c9e185dd94b8215aa77d02bbb8a2c"
DESCRIPTION="A very small C compiler for ix86/amd64"
HOMEPAGE="https://bellard.org/tcc/"
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://repo.or.cz/r/tinycc.git"
- SRC_URI=""
- scm_eclass=git-r3
+ inherit git-r3
+elif [[ ${PV} == *_p* ]] ; then
+ SRC_URI="https://repo.or.cz/tinycc.git/snapshot/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/tinycc-1645616
else
- KEYWORDS="~amd64 ~x86 ~amd64-linux"
SRC_URI="https://download.savannah.gnu.org/releases/tinycc/${P}.tar.bz2"
fi
-inherit toolchain-funcs ${scm_eclass}
-
LICENSE="LGPL-2.1"
SLOT="0"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86 ~amd64-linux"
+fi
-DEPEND="dev-lang/perl" # doc generation
-# Both tendra and tinycc install /usr/bin/tcc
-RDEPEND="!dev-lang/tendra"
+BDEPEND="dev-lang/perl" # doc generation
IUSE="test"
RESTRICT="!test? ( test )"
src_prepare() {
+ default
+
# Don't strip
- sed -i -e 's|$(INSTALL) -s|$(INSTALL)|' Makefile || die
+ sed -i \
+ -e 's|$(INSTALL) -s|$(INSTALL)|' \
+ -e 's|STRIP_yes = -s|STRIP_yes =|' \
+ Makefile || die
# Fix examples
sed -i -e '1{
@@ -37,16 +45,15 @@ src_prepare() {
}' examples/ex*.c || die
sed -i -e '1s/$/ -lX11/' examples/ex4.c || die
- # fix texi2html invocation
+ # Fix texi2html invocation
sed -i -e 's/-number//' Makefile || die
sed -i -e 's/--sections//' Makefile || die
-
- eapply_user
}
src_configure() {
use test && unset CFLAGS LDFLAGS # Tests run with CC=tcc etc, they will fail hard otherwise
# better fixes welcome, it feels wrong to hack the env like this
+
# not autotools, so call configure directly
./configure --cc="$(tc-getCC)" \
--prefix="${EPREFIX}/usr" \
@@ -58,6 +65,11 @@ src_compile() {
emake AR="$(tc-getAR)"
}
+src_test() {
+ # this is using tcc bits that don't know as-needed etc.
+ TCCFLAGS="" emake test
+}
+
src_install() {
emake DESTDIR="${D}" install
@@ -66,8 +78,3 @@ src_install() {
exeinto /usr/share/doc/${PF}/examples
doexe examples/ex*.c
}
-
-src_test() {
- # this is using tcc bits that don't know as-needed etc.
- TCCFLAGS="" emake test
-}