summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Joldasov <bratishkaerik@getgoogleoff.me>2022-10-27 01:00:03 +0600
committerSam James <sam@gentoo.org>2022-10-30 09:39:38 +0000
commit044b0969623c0c23f5884a22dfa58b02929b5086 (patch)
treec58b7e3b6c30ccd2409956f5e5ec52935673ac24 /dev-lang/zig/zig-9999.ebuild
parentx11-misc/qtfm: remove unused patch(es) (diff)
downloadgentoo-044b0969623c0c23f5884a22dfa58b02929b5086.tar.gz
gentoo-044b0969623c0c23f5884a22dfa58b02929b5086.tar.bz2
gentoo-044b0969623c0c23f5884a22dfa58b02929b5086.zip
dev-lang/zig: requires zstd support in LLVM
Starting with https://github.com/ziglang/zig/commit/d42a719e8f7ba31a9e18d6be9d58691b0b38c69a Zig requires zstd compression support. Zig requires zstd and zlib compression support in LLVM, if using LLVM backend (non-LLVM backends don't require these). They are not required "on their own", so please don't add them to dependencies. You can check https://github.com/ziglang/zig-bootstrap in future, to see options that are passed to LLVM CMake building (excluding "static" ofc). Signed-off-by: Eric Joldasov <bratishkaerik@getgoogleoff.me> Closes: https://github.com/gentoo/gentoo/pull/27964 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/zig/zig-9999.ebuild')
-rw-r--r--dev-lang/zig/zig-9999.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-lang/zig/zig-9999.ebuild b/dev-lang/zig/zig-9999.ebuild
index cc18f6e8a041..f4f7a100d588 100644
--- a/dev-lang/zig/zig-9999.ebuild
+++ b/dev-lang/zig/zig-9999.ebuild
@@ -23,11 +23,14 @@ RESTRICT="!test? ( test )"
BUILD_DIR="${S}/build"
+# Zig requires zstd and zlib compression support in LLVM, if using LLVM backend (non-LLVM backends don't require these).
+# They are not required "on their own", so please don't add them here.
+# You can check https://github.com/ziglang/zig-bootstrap in future, to see
+# options that are passed to LLVM CMake building (excluding "static" ofc).
DEPEND="
sys-devel/clang:${LLVM_MAX_SLOT}=
sys-devel/lld:${LLVM_MAX_SLOT}=
- sys-devel/llvm:${LLVM_MAX_SLOT}=
- >=sys-libs/zlib-1.2.12
+ sys-devel/llvm:${LLVM_MAX_SLOT}=[zstd]
"
RDEPEND="