summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-05-30 12:20:52 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-05-30 14:05:48 +0200
commit10b6f5f1a25e30aec4e4ea2eb1a5243bbcd90841 (patch)
treee77d33756701550f9161c3b92baa09f9579661c8 /dev-lang
parentdev-lang/eisl: drop old 2.97 (diff)
downloadgentoo-10b6f5f1a25e30aec4e4ea2eb1a5243bbcd90841.tar.gz
gentoo-10b6f5f1a25e30aec4e4ea2eb1a5243bbcd90841.tar.bz2
gentoo-10b6f5f1a25e30aec4e4ea2eb1a5243bbcd90841.zip
dev-lang/eisl: enable live
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/eisl/eisl-2.85.ebuild12
-rw-r--r--dev-lang/eisl/eisl-2.90.ebuild12
-rw-r--r--dev-lang/eisl/eisl-2.93.ebuild12
-rw-r--r--dev-lang/eisl/eisl-2.98.ebuild12
4 files changed, 36 insertions, 12 deletions
diff --git a/dev-lang/eisl/eisl-2.85.ebuild b/dev-lang/eisl/eisl-2.85.ebuild
index 8f1958272ec6..d1fa86560db1 100644
--- a/dev-lang/eisl/eisl-2.85.ebuild
+++ b/dev-lang/eisl/eisl-2.85.ebuild
@@ -7,12 +7,18 @@ inherit toolchain-funcs
DESCRIPTION="Interpreter and compiler compatible with the ISLisp standard"
HOMEPAGE="https://github.com/sasagawa888/eisl/"
-SRC_URI="https://github.com/sasagawa888/eisl/archive/v${PV}.tar.gz
- -> ${P}.tar.gz"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/sasagawa888/${PN}.git"
+else
+ SRC_URI="https://github.com/sasagawa888/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="amd64 ~x86"
+fi
LICENSE="BSD-2"
SLOT="0"
-KEYWORDS="amd64 ~x86"
RESTRICT="test" # Tests run cppcheck (and fail)
DOCS=( README{,-ja}.md documents )
diff --git a/dev-lang/eisl/eisl-2.90.ebuild b/dev-lang/eisl/eisl-2.90.ebuild
index 43db8b7e7b07..05fe23762b19 100644
--- a/dev-lang/eisl/eisl-2.90.ebuild
+++ b/dev-lang/eisl/eisl-2.90.ebuild
@@ -7,12 +7,18 @@ inherit toolchain-funcs
DESCRIPTION="Interpreter and compiler compatible with the ISLisp standard"
HOMEPAGE="https://github.com/sasagawa888/eisl/"
-SRC_URI="https://github.com/sasagawa888/eisl/archive/v${PV}.tar.gz
- -> ${P}.tar.gz"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/sasagawa888/${PN}.git"
+else
+ SRC_URI="https://github.com/sasagawa888/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="amd64 ~x86"
+fi
LICENSE="BSD-2"
SLOT="0"
-KEYWORDS="amd64 ~x86"
RESTRICT="test" # Tests run cppcheck (and fail)
DOCS=( README{,-ja}.md documents )
diff --git a/dev-lang/eisl/eisl-2.93.ebuild b/dev-lang/eisl/eisl-2.93.ebuild
index fc6d817410fa..987db06ada03 100644
--- a/dev-lang/eisl/eisl-2.93.ebuild
+++ b/dev-lang/eisl/eisl-2.93.ebuild
@@ -7,12 +7,18 @@ inherit toolchain-funcs
DESCRIPTION="Interpreter and compiler compatible with the ISLisp standard"
HOMEPAGE="https://github.com/sasagawa888/eisl/"
-SRC_URI="https://github.com/sasagawa888/${PN}/archive/v${PV}.tar.gz
- -> ${P}.tar.gz"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/sasagawa888/${PN}.git"
+else
+ SRC_URI="https://github.com/sasagawa888/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
LICENSE="BSD-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
RESTRICT="test" # Tests run cppcheck (and fail)
DOCS=( README{,-ja}.md documents )
diff --git a/dev-lang/eisl/eisl-2.98.ebuild b/dev-lang/eisl/eisl-2.98.ebuild
index fc6d817410fa..987db06ada03 100644
--- a/dev-lang/eisl/eisl-2.98.ebuild
+++ b/dev-lang/eisl/eisl-2.98.ebuild
@@ -7,12 +7,18 @@ inherit toolchain-funcs
DESCRIPTION="Interpreter and compiler compatible with the ISLisp standard"
HOMEPAGE="https://github.com/sasagawa888/eisl/"
-SRC_URI="https://github.com/sasagawa888/${PN}/archive/v${PV}.tar.gz
- -> ${P}.tar.gz"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/sasagawa888/${PN}.git"
+else
+ SRC_URI="https://github.com/sasagawa888/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
LICENSE="BSD-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
RESTRICT="test" # Tests run cppcheck (and fail)
DOCS=( README{,-ja}.md documents )