summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-27 07:05:11 +0100
committerSam James <sam@gentoo.org>2022-08-27 07:06:35 +0100
commit7c05061c40634d9a1adc02c17ffaff53fcfa65e8 (patch)
tree538a9d8eb1624c7243b5e759962212102909ba2d /dev-libs/boehm-gc/boehm-gc-8.2.2.ebuild
parentdev-libs/boehm-gc: add 8.0.8 (diff)
downloadgentoo-7c05061c40634d9a1adc02c17ffaff53fcfa65e8.tar.gz
gentoo-7c05061c40634d9a1adc02c17ffaff53fcfa65e8.tar.bz2
gentoo-7c05061c40634d9a1adc02c17ffaff53fcfa65e8.zip
dev-libs/boehm-gc: add 8.2.2
No longer marked as a pre-release. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/boehm-gc/boehm-gc-8.2.2.ebuild')
-rw-r--r--dev-libs/boehm-gc/boehm-gc-8.2.2.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-libs/boehm-gc/boehm-gc-8.2.2.ebuild b/dev-libs/boehm-gc/boehm-gc-8.2.2.ebuild
new file mode 100644
index 000000000000..0d463fd97be6
--- /dev/null
+++ b/dev-libs/boehm-gc/boehm-gc-8.2.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal libtool
+
+MY_P="gc-${PV}"
+
+DESCRIPTION="The Boehm-Demers-Weiser conservative garbage collector"
+HOMEPAGE="https://www.hboehm.info/gc/ https://github.com/ivmai/bdwgc/"
+SRC_URI="https://github.com/ivmai/bdwgc/releases/download/v${PV}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="boehm-gc"
+# SONAME: libgc.so.1 libgccpp.so.1
+# We've been using subslot 0 for these instead of "1.1".
+SLOT="0"
+# Upstream marked this version as "Pre-release"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="cxx +large static-libs +threads"
+
+RDEPEND=">=dev-libs/libatomic_ops-7.4[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # bug #594754
+ elibtoolize
+}
+
+multilib_src_configure() {
+ local config=(
+ --disable-docs
+ --with-libatomic-ops
+ $(use_enable cxx cplusplus)
+ $(use_enable static-libs static)
+ $(use threads || echo --disable-threads)
+ $(use_enable large large-config)
+ )
+
+ ECONF_SOURCE="${S}" econf "${config[@]}"
+}
+
+multilib_src_install_all() {
+ local HTML_DOCS=( doc/*.md )
+ einstalldocs
+ dodoc doc/README{.environment,.linux,.macros}
+
+ # Package provides .pc files
+ find "${ED}" -name '*.la' -delete || die
+
+ newman doc/gc.man GC_malloc.1
+}