summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-19 03:17:56 +0000
committerSam James <sam@gentoo.org>2021-05-19 03:17:56 +0000
commit2fec2a9762b893d6e497445c4f79df26e438735e (patch)
tree644bed1b8adb0a9f2483b6e04fb6d0304465c9b6 /dev-libs/cdk
parentgames-arcade/thinktanks-demo: update Manifest for SRC_URI change (diff)
downloadgentoo-2fec2a9762b893d6e497445c4f79df26e438735e.tar.gz
gentoo-2fec2a9762b893d6e497445c4f79df26e438735e.tar.bz2
gentoo-2fec2a9762b893d6e497445c4f79df26e438735e.zip
dev-libs/cdk: drop libtool
In some cases, configure seems to be producing a Makefile with a broken install target (which lacks the needed libtool install finalisation). Let's just disable libtool for now, we don't need it. Closes: https://bugs.gentoo.org/790773 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/cdk')
-rw-r--r--dev-libs/cdk/cdk-5.0.20210324-r1.ebuild (renamed from dev-libs/cdk/cdk-5.0.20210324.ebuild)9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-libs/cdk/cdk-5.0.20210324.ebuild b/dev-libs/cdk/cdk-5.0.20210324-r1.ebuild
index 30eddf517e27..6aee2fbce644 100644
--- a/dev-libs/cdk/cdk-5.0.20210324.ebuild
+++ b/dev-libs/cdk/cdk-5.0.20210324-r1.ebuild
@@ -17,8 +17,7 @@ IUSE="examples unicode"
DEPEND=">=sys-libs/ncurses-5.2:0=[unicode?]"
RDEPEND="${DEPEND}"
-BDEPEND="sys-devel/libtool
- virtual/pkgconfig"
+BDEPEND="virtual/pkgconfig"
PATCHES=( "${FILESDIR}"/${PN}-5.0.20120323-parallel-make.patch )
@@ -27,9 +26,10 @@ src_configure() {
export ac_cv_prog_LIBTOOL=glibtool
fi
+ # --with-libtool dropped for now because of broken Makefile
+ # bug #790773
econf \
--disable-rpath-hack \
- --with-libtool \
--with-shared \
--with-pkg-config \
--with-ncurses$(usex unicode "w" "")
@@ -39,7 +39,8 @@ src_install() {
# parallel make installs duplicate libs
emake -j1 \
DESTDIR="${D}" \
- DOCUMENT_DIR="${ED}/usr/share/doc/${PF}" install
+ DOCUMENT_DIR="${ED}/usr/share/doc/${PF}" \
+ install
if use examples ; then
local x