summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-01-07 07:24:49 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-01-07 07:38:49 +0100
commit8f1f995767be0e811ab1c0c213e6e586952af976 (patch)
tree03bf43c81e7ab5fac21bb88ca891da1dab13b092 /dev-libs/collada-dom/collada-dom-2.5.0.ebuild
parentros-meta/geometry_experimental: Bump to 0.5.17. (diff)
downloadgentoo-8f1f995767be0e811ab1c0c213e6e586952af976.tar.gz
gentoo-8f1f995767be0e811ab1c0c213e6e586952af976.tar.bz2
gentoo-8f1f995767be0e811ab1c0c213e6e586952af976.zip
dev-libs/collada-dom: bump to 2.5.0
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-libs/collada-dom/collada-dom-2.5.0.ebuild')
-rw-r--r--dev-libs/collada-dom/collada-dom-2.5.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/collada-dom/collada-dom-2.5.0.ebuild b/dev-libs/collada-dom/collada-dom-2.5.0.ebuild
new file mode 100644
index 000000000000..46cc5b8cffbf
--- /dev/null
+++ b/dev-libs/collada-dom/collada-dom-2.5.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/rdiankov/collada-dom"
+fi
+
+inherit ${SCM} cmake-utils
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+ SRC_URI=""
+elif [ "${PV%_pre*}" != "${PV}" ]; then
+ # snapshot
+ KEYWORDS="~amd64 ~arm"
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+else
+ KEYWORDS="~amd64 ~arm"
+ SRC_URI="https://github.com/rdiankov/collada-dom/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="COLLADA Document Object Model (DOM) C++ Library"
+HOMEPAGE="https://github.com/rdiankov/collada-dom"
+
+LICENSE="MIT"
+SLOT="0/25"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ sys-libs/zlib:=[minizip]
+ dev-libs/libxml2
+ dev-libs/libpcre[cxx]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"