summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2024-05-27 19:34:37 +0300
committerStefan Strogin <steils@gentoo.org>2024-05-28 08:29:03 +0000
commitcd9beeb0008adf8a9d48187d4d35aef779c5a2d4 (patch)
tree97fab2768220ddf29e0b368429b18d52dc83a39f /dev-libs/collada-dom
parentx11-wm/metacity: add 3.52.0 (diff)
downloadgentoo-cd9beeb0008adf8a9d48187d4d35aef779c5a2d4.tar.gz
gentoo-cd9beeb0008adf8a9d48187d4d35aef779c5a2d4.tar.bz2
gentoo-cd9beeb0008adf8a9d48187d4d35aef779c5a2d4.zip
dev-libs/collada-dom: fix build with boost-1.85.0
Closes: https://bugs.gentoo.org/932316 Signed-off-by: Stefan Strogin <steils@gentoo.org>
Diffstat (limited to 'dev-libs/collada-dom')
-rw-r--r--dev-libs/collada-dom/collada-dom-2.5.0-r1.ebuild4
-rw-r--r--dev-libs/collada-dom/files/collada-dom-2.5.0-boost-1.85.patch45
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-libs/collada-dom/collada-dom-2.5.0-r1.ebuild b/dev-libs/collada-dom/collada-dom-2.5.0-r1.ebuild
index f227b381ce14..ed5d9520144b 100644
--- a/dev-libs/collada-dom/collada-dom-2.5.0-r1.ebuild
+++ b/dev-libs/collada-dom/collada-dom-2.5.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -27,6 +27,8 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
+PATCHES=( "${FILESDIR}/${PN}-2.5.0-boost-1.85.patch" )
+
src_configure() {
# bug 618960
append-cxxflags -std=c++14
diff --git a/dev-libs/collada-dom/files/collada-dom-2.5.0-boost-1.85.patch b/dev-libs/collada-dom/files/collada-dom-2.5.0-boost-1.85.patch
new file mode 100644
index 000000000000..0a6e6e8869e8
--- /dev/null
+++ b/dev-libs/collada-dom/files/collada-dom-2.5.0-boost-1.85.patch
@@ -0,0 +1,45 @@
+commit 65222c3c4f800b624e1d547ab7f1eb28e3d6ee59
+Author: Stefan Strogin <stefan@steils.org>
+Date: Mon May 27 16:13:09 2024 +0000
+
+ Fix build for boost 1.85.0, #42
+
+diff --git a/dom/include/dae.h b/dom/include/dae.h
+index e53388b..03e72f9 100644
+--- a/dom/include/dae.h
++++ b/dom/include/dae.h
+@@ -25,7 +25,7 @@
+ #pragma warning(disable: 4180 4245)
+ #endif
+ #ifndef NO_BOOST
+-#include <boost/filesystem/convenience.hpp>
++#include <boost/filesystem.hpp>
+ #endif
+ #ifdef _MSC_VER
+ #pragma warning(pop)
+diff --git a/dom/src/dae/daeUtils.cpp b/dom/src/dae/daeUtils.cpp
+index de30ca0..45b667f 100644
+--- a/dom/src/dae/daeUtils.cpp
++++ b/dom/src/dae/daeUtils.cpp
+@@ -18,7 +18,7 @@
+ #endif
+
+ #ifndef NO_BOOST
+-#include <boost/filesystem/convenience.hpp> // THIS WAS NOT COMMENTED.
++#include <boost/filesystem.hpp> // THIS WAS NOT COMMENTED.
+ #endif
+
+ #include <cstdio> // for tmpnam
+diff --git a/dom/src/dae/daeZAEUncompressHandler.cpp b/dom/src/dae/daeZAEUncompressHandler.cpp
+index da2a344..2550000 100644
+--- a/dom/src/dae/daeZAEUncompressHandler.cpp
++++ b/dom/src/dae/daeZAEUncompressHandler.cpp
+@@ -271,7 +271,7 @@ bool daeZAEUncompressHandler::checkAndExtractInternalArchive( const std::string&
+ bool error = false;
+
+ boost::filesystem::path archivePath(filePath);
+- std::string dir = archivePath.branch_path().string();
++ std::string dir = archivePath.parent_path().string();
+
+ const std::string& randomSegment = cdom::getRandomFileName();
+ std::string tmpDir = dir + cdom::getFileSeparator() + randomSegment + cdom::getFileSeparator();