summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-10-06 11:46:20 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-10-06 11:48:21 +0200
commitbe4310724d3487a2bc1ff2005296d750bc85d599 (patch)
tree88bf7e6dd0025afc9ee182e9687b60fbc5c8ca41 /dev-libs/icu-le-hb
parentdev-python/pymetar: update EAPI 7 -> 8, pep517, add tests, enable py3_{10,11} (diff)
downloadgentoo-be4310724d3487a2bc1ff2005296d750bc85d599.tar.gz
gentoo-be4310724d3487a2bc1ff2005296d750bc85d599.tar.bz2
gentoo-be4310724d3487a2bc1ff2005296d750bc85d599.zip
dev-libs/icu-le-hb: add 1.2.3
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/icu-le-hb')
-rw-r--r--dev-libs/icu-le-hb/Manifest1
-rw-r--r--dev-libs/icu-le-hb/icu-le-hb-1.2.3.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/icu-le-hb/Manifest b/dev-libs/icu-le-hb/Manifest
index 7770507eacdd..dadf9ea9fddb 100644
--- a/dev-libs/icu-le-hb/Manifest
+++ b/dev-libs/icu-le-hb/Manifest
@@ -1 +1,2 @@
DIST icu-le-hb-1.0.3.tar.gz 39352 BLAKE2B 7cc2e56b6ac334e0f9c259d4f9d0356480c1ae4eb647610ebfb81ee9b1bc0326f1dba68991e2893cc9b029ea53705cc0936cbbf29e74ab4ef336f58f5e8b47ab SHA512 06dff69bc17c39c13bd5bc801dbe09e2dc2f0cdf1acd774fa863e09f4a65820b2f330d4836da6748c077365f685fa74452ec1924785e3191cc2925036803cbb4
+DIST icu-le-hb-1.2.3.tar.gz 45191 BLAKE2B 14ad8592a27ff8673d9609a689bedf5094c127bb9cb638a1e65c1fcb6e22e8c488f89e55af5578cd4961a34feafffd5df9cdedb20dfc7edcc4d6f63aec1eff0f SHA512 c1450e28c1984a409cacc2b675ab91fa0e80edfbbfb201913cb83e435fd30f3a3ad78ca32f8cf092c5f056f2812b899ceb4471b36ef975faf5be892d305a1efd
diff --git a/dev-libs/icu-le-hb/icu-le-hb-1.2.3.ebuild b/dev-libs/icu-le-hb/icu-le-hb-1.2.3.ebuild
new file mode 100644
index 000000000000..4534ccb749b8
--- /dev/null
+++ b/dev-libs/icu-le-hb/icu-le-hb-1.2.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="ICU Layout Engine API on top of HarfBuzz shaping library"
+HOMEPAGE="https://github.com/harfbuzz/harfbuzz
+https://github.com/harfbuzz/icu-le-hb"
+SRC_URI="https://github.com/behdad/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="icu"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# dev-libs/icu is not linked into icu-le-hb but the latter still needs
+# to be rebuilt on dev-libs/icu upgrades (see bug #621786).
+RDEPEND="
+ dev-libs/icu:=[${MULTILIB_USEDEP}]
+ media-libs/harfbuzz:=[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f -name "*.la" -delete || die
+}