summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai Krakow <kai@kaishome.de>2020-09-20 13:07:29 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-09-28 14:32:58 +0300
commit5868d5bb08a143eedab0ab9a6066f5b3e6eae68a (patch)
treee6f3452abe1647f636fec8f60e3a61f4e77f20fe /dev-libs/inih
parentdev-libs/aws-sdk-cpp: Fixed dependencies and a typo (diff)
downloadgentoo-5868d5bb08a143eedab0ab9a6066f5b3e6eae68a.tar.gz
gentoo-5868d5bb08a143eedab0ab9a6066f5b3e6eae68a.tar.bz2
gentoo-5868d5bb08a143eedab0ab9a6066f5b3e6eae68a.zip
dev-libs/inih: New ebuild
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Kai Krakow <kai@kaishome.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/inih')
-rw-r--r--dev-libs/inih/Manifest1
-rw-r--r--dev-libs/inih/inih-51.ebuild42
-rw-r--r--dev-libs/inih/metadata.xml16
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-libs/inih/Manifest b/dev-libs/inih/Manifest
new file mode 100644
index 000000000000..cbef149096ed
--- /dev/null
+++ b/dev-libs/inih/Manifest
@@ -0,0 +1 @@
+DIST inih-51.tar.gz 16258 BLAKE2B 91a5aee6e0ecadf949fbf0b58bd2596bcb985c76fc9000a671d65cb5325c51dbb8bd945ccd7721b72dafafd11c70a9c84ad910768d0fc479e5491db8b7aacbd8 SHA512 eb2f58979d93e51a09326e6c187828643887ac1a239d4b12205567c7d87a671c9c49ca99db376c031d366bc680e579c30dcea9f3eb130ec802597411b2cb3cf4
diff --git a/dev-libs/inih/inih-51.ebuild b/dev-libs/inih/inih-51.ebuild
new file mode 100644
index 000000000000..3cbd85dd6604
--- /dev/null
+++ b/dev-libs/inih/inih-51.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MULTILIB_COMPAT=( abi_x86_{32,64} )
+
+inherit meson multilib-minimal ninja-utils
+
+DESCRIPTION="inih (INI not invented here) simple .INI file parser"
+HOMEPAGE="https://github.com/benhoyt/inih"
+
+SRC_URI="https://github.com/benhoyt/inih/archive/r${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="BSD"
+SLOT="0"
+
+DOCS=(
+ LICENSE.txt
+ README.md
+)
+
+S="${WORKDIR}/inih-r${PV}"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_library=shared
+ -Ddistro_install=true
+ -Dwith_INIReader=true
+ )
+
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ eninja
+}
+
+multilib_src_install() {
+ DESTDIR="${D}" eninja install
+}
diff --git a/dev-libs/inih/metadata.xml b/dev-libs/inih/metadata.xml
new file mode 100644
index 000000000000..9aa6590570ff
--- /dev/null
+++ b/dev-libs/inih/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>hurikhan77+bgo@gmail.com</email>
+ <name>Kai Krakow</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/benhoyt/inih/issues</bugs-to>
+ <remote-id type="github">benhoyt/inih</remote-id>
+ </upstream>
+</pkgmetadata>