summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-07-22 20:46:52 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-07-25 22:04:11 +0200
commit2ba8aef245ea39c2a5f7437de78ff1be5a1854a4 (patch)
tree1455cdd36a3f39b3bc1fb139e1a008e991c14ea1 /dev-libs/kdsingleapplication
parentdev-qt/kdsingleapplication: pkgmove to dev-libs/kdsingleapplication (diff)
downloadgentoo-2ba8aef245ea39c2a5f7437de78ff1be5a1854a4.tar.gz
gentoo-2ba8aef245ea39c2a5f7437de78ff1be5a1854a4.tar.bz2
gentoo-2ba8aef245ea39c2a5f7437de78ff1be5a1854a4.zip
dev-libs/kdsingleapplication: Drop IUSE qt6 (dropping qt5 "option")
- Fix IUSE doc, examples - Use qmake-utils to set QHELPGEN_EXECUTABLE - Simplify src_install(), cmake_src_install calls einstalldocs - Do not use rm -f (we want to know when sth. breaks) - Arrayify HTML_DOCS and make local Bug: https://bugs.gentoo.org/935012 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/kdsingleapplication')
-rw-r--r--dev-libs/kdsingleapplication/kdsingleapplication-1.1.0-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-libs/kdsingleapplication/kdsingleapplication-1.1.0-r1.ebuild b/dev-libs/kdsingleapplication/kdsingleapplication-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..6614a67561d6
--- /dev/null
+++ b/dev-libs/kdsingleapplication/kdsingleapplication-1.1.0-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake qmake-utils
+
+DESCRIPTION="KDAB's helper class for single-instance policy applications"
+HOMEPAGE="https://github.com/KDAB/KDSingleApplication"
+SRC_URI="https://github.com/KDAB/KDSingleApplication/releases/download/v${PV}/kdsingleapplication-${PV}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-qt/qtbase:6[network,widgets]"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ doc? (
+ app-text/doxygen[dot]
+ dev-qt/qttools:6[assistant]
+ )
+ examples? ( dev-util/patchelf )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_DOC_DIR="${EPREFIX}/usr/share/doc/${PF}"
+ -DKDSingleApplication_QT6=ON
+ -DKDSingleApplication_DOCS=$(usex doc)
+ -DKDSingleApplication_EXAMPLES=$(usex examples)
+ -DKDSingleApplication_TESTS=$(usex test)
+ )
+ use examples && mycmakeargs+=(
+ -DQHELPGEN_EXECUTABLE="$(qt6_get_bindir)/../libexec/qhelpgenerator"
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ if use doc; then
+ if use examples; then
+ rm -r "${BUILD_DIR}"/docs/api/html/examples || die
+ fi
+ local HTML_DOCS=( "${BUILD_DIR}"/docs/api/html/. )
+ fi
+ if use examples; then
+ patchelf --remove-rpath "${BUILD_DIR}"/bin/widgetsingleapplication || die
+ dobin "${BUILD_DIR}"/bin/widgetsingleapplication
+ fi
+ cmake_src_install
+}