summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-07-03 18:55:38 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-07-04 13:50:25 +0200
commit8f1bd0117e36d26a84759ae63757216b25feb990 (patch)
tree430cd4454985a90c0df407be282637cc154d6207 /dev-libs/kosmindoormap
parentdev-libs/kopeninghours: 24.05.2 version bump (diff)
downloadgentoo-8f1bd0117e36d26a84759ae63757216b25feb990.tar.gz
gentoo-8f1bd0117e36d26a84759ae63757216b25feb990.tar.bz2
gentoo-8f1bd0117e36d26a84759ae63757216b25feb990.zip
dev-libs/kosmindoormap: 24.05.2 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/kosmindoormap')
-rw-r--r--dev-libs/kosmindoormap/Manifest1
-rw-r--r--dev-libs/kosmindoormap/kosmindoormap-24.05.2.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-libs/kosmindoormap/Manifest b/dev-libs/kosmindoormap/Manifest
index 716c6398ceac..ff8ee428393b 100644
--- a/dev-libs/kosmindoormap/Manifest
+++ b/dev-libs/kosmindoormap/Manifest
@@ -1,2 +1,3 @@
DIST kosmindoormap-23.08.5.tar.xz 384948 BLAKE2B 0936fe42b0c370dc0c57d475aa771784c75e8350e2d563140c027d047514840f99d6697e36fde027da11e22a92239b6403cf1b18a37aa8e09a3f8814cb6931c8 SHA512 9128cccbd56f51b1e8ad7f7151db0de8952a8348fb74afe3eefeb085979b26d95d1699f260d744c4f3ea5d815109f998829625db480194a8539e782e8c32537c
DIST kosmindoormap-24.05.1.tar.xz 645860 BLAKE2B 73e7e8bf2511e59c06d43f9264ec0733bc10e7cce338174ce5b52f64fdb27b198ccfe10d3722e155367830489577e36691bd2cb861f53725e2cf45434e514d16 SHA512 ab96b13ba9f5ffb9fb7dae1bc4803dcc95525214fe54058634a0c3063dff5191831b1778ac6c758c860e84c923f9e14d1d3edeeacb6b309aab170c608503bb2e
+DIST kosmindoormap-24.05.2.tar.xz 647752 BLAKE2B 9464b424669a412b4b32958ced91c0dae9980e9387cc97b823bcdaecffca850d29f25e9b437fc1d3b4d8b0d8022c6fc7b0a8e176a20f72ee2714da1691207838 SHA512 2bf2998be61893d651dbd1a9a0e509c6cf83a122e9ee95c265bf0507706c77b20b7e64d462840d76c7b1aa6f9d884305812e32dc4058c09a0f724994d2e073b1
diff --git a/dev-libs/kosmindoormap/kosmindoormap-24.05.2.ebuild b/dev-libs/kosmindoormap/kosmindoormap-24.05.2.ebuild
new file mode 100644
index 000000000000..5dc6d3d36d64
--- /dev/null
+++ b/dev-libs/kosmindoormap/kosmindoormap-24.05.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.3.0
+QTMIN=6.6.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Data Model and Extraction System for Travel Reservation information"
+HOMEPAGE="https://invent.kde.org/libraries/kosmindoormap"
+
+LICENSE="LGPL-2+"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64"
+IUSE="+gui"
+
+# kservice is optional and only used to find and open josm
+RDEPEND="
+ dev-libs/protobuf:=
+ >=dev-qt/qtbase-${QTMIN}:6[gui?,network]
+ sys-libs/zlib
+ gui? (
+ >=dev-libs/kopeninghours-${PVCUT}:6
+ >=dev-libs/kpublictransport-${PVCUT}:6
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kservice-${KFMIN}:6
+ )
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-qt/qtbase-${QTMIN}:6[widgets] )
+"
+BDEPEND="
+ app-alternatives/lex
+ app-alternatives/yacc
+"
+
+# Pending: https://invent.kde.org/libraries/kosmindoormap/-/merge_requests/40
+PATCHES=( "${FILESDIR}/${PN}-24.05.1-cmake.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TOOLS_ONLY=$(usex !gui)
+ -DCMAKE_DISABLE_FIND_PACKAGE_OsmTools=ON # we have no use for it
+ )
+ ecm_src_configure
+}