summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2015-10-21 02:59:42 +0200
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2015-10-21 02:59:42 +0200
commit3810119628ad161b2eba665b20a9ec096d991271 (patch)
tree754514cd3e173c946e3f12c5db4d1cf6d02c37fd /dev-libs/libclc/libclc-0.2.0_pre20151006.ebuild
parentdev-libs/bcm2835: Remove old. (diff)
downloadgentoo-3810119628ad161b2eba665b20a9ec096d991271.tar.gz
gentoo-3810119628ad161b2eba665b20a9ec096d991271.tar.bz2
gentoo-3810119628ad161b2eba665b20a9ec096d991271.zip
dev-libs/libclc: Add new snapshot for llvm-3.7 compatibility
Bug: https://bugs.gentoo.org/show_bug.cgi?id=559546 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-libs/libclc/libclc-0.2.0_pre20151006.ebuild')
-rw-r--r--dev-libs/libclc/libclc-0.2.0_pre20151006.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/libclc/libclc-0.2.0_pre20151006.ebuild b/dev-libs/libclc/libclc-0.2.0_pre20151006.ebuild
new file mode 100644
index 000000000000..36d9086cdcbf
--- /dev/null
+++ b/dev-libs/libclc/libclc-0.2.0_pre20151006.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+EGIT_REPO_URI="http://llvm.org/git/${PN}.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EXPERIMENTAL="true"
+fi
+
+inherit base python-any-r1 $GIT_ECLASS
+
+DESCRIPTION="OpenCL C library"
+HOMEPAGE="http://libclc.llvm.org/"
+
+if [[ $PV = 9999* ]]; then
+ SRC_URI="${SRC_PATCHES}"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz ${SRC_PATCHES}"
+fi
+
+LICENSE="|| ( MIT BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=sys-devel/clang-3.7
+ >=sys-devel/llvm-3.7"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}"
+
+src_unpack() {
+ if [[ $PV = 9999* ]]; then
+ git-r3_src_unpack
+ else
+ default
+ mv ${PN}-*/ ${P} || die
+ fi
+}
+
+src_configure() {
+ ./configure.py \
+ --with-llvm-config="${EPREFIX}/usr/bin/llvm-config" \
+ --prefix="${EPREFIX}/usr" || die
+}
+
+src_compile() {
+ emake VERBOSE=1
+}