summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2022-04-16 15:32:25 -0400
committerMike Gilbert <floppym@gentoo.org>2022-04-16 15:34:26 -0400
commiteadc4f710b6783d509cb6d9b2b5b475069e16391 (patch)
tree0cb4dfe15b62e8ec94f141adf0b623b477e7be10 /dev-libs/libgcrypt/libgcrypt-1.9.4-r1.ebuild
parentsci-geosciences/qgis: add 3.22.6 (diff)
downloadgentoo-eadc4f710b6783d509cb6d9b2b5b475069e16391.tar.gz
gentoo-eadc4f710b6783d509cb6d9b2b5b475069e16391.tar.bz2
gentoo-eadc4f710b6783d509cb6d9b2b5b475069e16391.zip
dev-libs/libgcrypt: always enable O-flag-munging
Exposing this as a USE flag is mostly pointless, and results in silly bug reports from users who disable it by accident. Users can disable it using EXTRA_ECONF if so desired. Bug: https://bugs.gentoo.org/629410 Bug: https://bugs.gentoo.org/707330 Closes: https://bugs.gentoo.org/838472 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-libs/libgcrypt/libgcrypt-1.9.4-r1.ebuild')
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.9.4-r1.ebuild3
1 files changed, 1 insertions, 2 deletions
diff --git a/dev-libs/libgcrypt/libgcrypt-1.9.4-r1.ebuild b/dev-libs/libgcrypt/libgcrypt-1.9.4-r1.ebuild
index 8a228b0fe2c4..6c29e69188e1 100644
--- a/dev-libs/libgcrypt/libgcrypt-1.9.4-r1.ebuild
+++ b/dev-libs/libgcrypt/libgcrypt-1.9.4-r1.ebuild
@@ -14,7 +14,7 @@ SRC_URI+=" verify-sig? ( mirror://gnupg/${PN}/${P}.tar.bz2.sig )"
LICENSE="LGPL-2.1 MIT"
SLOT="0/20" # subslot = soname major version
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="+asm custom-cflags cpu_flags_arm_neon cpu_flags_arm_aes cpu_flags_arm_sha1 cpu_flags_arm_sha2 cpu_flags_ppc_altivec cpu_flags_ppc_vsx2 cpu_flags_ppc_vsx3 cpu_flags_x86_aes cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_padlock cpu_flags_x86_sha cpu_flags_x86_sse4_1 doc static-libs"
+IUSE="+asm cpu_flags_arm_neon cpu_flags_arm_aes cpu_flags_arm_sha1 cpu_flags_arm_sha2 cpu_flags_ppc_altivec cpu_flags_ppc_vsx2 cpu_flags_ppc_vsx3 cpu_flags_x86_aes cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_padlock cpu_flags_x86_sha cpu_flags_x86_sse4_1 doc static-libs"
# Build system only has --disable-arm-crypto-support right now
# If changing this, update src_configure logic too.
@@ -93,7 +93,6 @@ multilib_src_configure() {
$(use_enable cpu_flags_x86_sse4_1 sse41-support)
# required for sys-power/suspend[crypt], bug 751568
$(use_enable static-libs static)
- $(use_enable !custom-cflags O-flag-munging)
# disabled due to various applications requiring privileges
# after libgcrypt drops them (bug #468616)