summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2023-11-23 12:31:18 +0000
committerYixun Lan <dlan@gentoo.org>2023-11-23 12:31:18 +0000
commitebe5848bed0768b42a94be512513901f5061baf2 (patch)
tree524269e55126c8e550d1d8517583d5769c6caefd /dev-libs/libgpiod/libgpiod-2.1.ebuild
parentdev-util/crash: drop 8.0.2 (diff)
downloadgentoo-ebe5848bed0768b42a94be512513901f5061baf2.tar.gz
gentoo-ebe5848bed0768b42a94be512513901f5061baf2.tar.bz2
gentoo-ebe5848bed0768b42a94be512513901f5061baf2.zip
dev-libs/libgpiod: add 2.1
Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-libs/libgpiod/libgpiod-2.1.ebuild')
-rw-r--r--dev-libs/libgpiod/libgpiod-2.1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-libs/libgpiod/libgpiod-2.1.ebuild b/dev-libs/libgpiod/libgpiod-2.1.ebuild
new file mode 100644
index 000000000000..94df11b5ec4b
--- /dev/null
+++ b/dev-libs/libgpiod/libgpiod-2.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info
+
+DESCRIPTION="C library and tools for interacting with the linux GPIO character device"
+HOMEPAGE="https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git/"
+SRC_URI="https://mirrors.edge.kernel.org/pub/software/libs/libgpiod/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+# Reflects the ABI of libgpiod.so
+SLOT="0/3"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+IUSE="+tools cxx python test"
+RESTRICT="!test? ( test )"
+
+# --enable-tests enable libgpiod tests [default=no]
+# --enable-bindings-cxx enable C++ bindings [default=no]
+# --enable-bindings-python
+# --enable-bindings-rust
+DEPEND="
+ test? (
+ >=dev-libs/glib-2.50
+ >=sys-apps/kmod-18
+ >=sys-apps/util-linux-2.33.1
+ >=virtual/libudev-215
+ )
+"
+
+pkg_setup() {
+ CONFIG_CHECK="~GPIO_CDEV_V1"
+ linux-info_pkg_setup
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable tools)
+ $(use_enable cxx bindings-cxx)
+ $(use_enable test tests)
+ $(use_enable python bindings-python)
+ --enable-examples
+ --disable-profiling
+ --disable-bindings-rust
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -type f -delete || die
+ find "${D}" -name "*.a" -delete || die
+}