summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-09 09:58:54 +0200
committerDavid Seifert <soap@gentoo.org>2022-09-09 09:58:54 +0200
commitf7abc151015b8fa7d2c398008f8656368729a4cf (patch)
tree30cd2e990c2705c430cc5efa579d5ba50bf8c617 /dev-libs/libgpiod
parentdev-libs/libfmt: drop multilib (diff)
downloadgentoo-f7abc151015b8fa7d2c398008f8656368729a4cf.tar.gz
gentoo-f7abc151015b8fa7d2c398008f8656368729a4cf.tar.bz2
gentoo-f7abc151015b8fa7d2c398008f8656368729a4cf.zip
dev-libs/libgpiod: drop multilib, static-libs
No multilib or static-libs reverse dependencies. Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/libgpiod')
-rw-r--r--dev-libs/libgpiod/libgpiod-1.6.3-r4.ebuild (renamed from dev-libs/libgpiod/libgpiod-1.6.3-r3.ebuild)23
1 files changed, 7 insertions, 16 deletions
diff --git a/dev-libs/libgpiod/libgpiod-1.6.3-r3.ebuild b/dev-libs/libgpiod/libgpiod-1.6.3-r4.ebuild
index 83669f2db358..98464819a577 100644
--- a/dev-libs/libgpiod/libgpiod-1.6.3-r3.ebuild
+++ b/dev-libs/libgpiod/libgpiod-1.6.3-r4.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit linux-info multilib-minimal
+inherit linux-info
DESCRIPTION="C library and tools for interacting with the linux GPIO character device"
HOMEPAGE="https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git/"
@@ -13,7 +13,7 @@ LICENSE="LGPL-2.1"
# Reflects the ABI of libgpiod.so
SLOT="0/2"
KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
-IUSE="static-libs +tools cxx python test"
+IUSE="+tools cxx python test"
RESTRICT="!test? ( test )"
# --enable-tests enable libgpiod tests [default=no]
@@ -25,29 +25,20 @@ pkg_setup() {
linux-info_pkg_setup
}
-multilib_src_configure() {
+src_configure() {
local myconf=(
$(use_enable tools)
$(use_enable cxx bindings-cxx)
$(use_enable test tests)
- $(multilib_native_use_enable python bindings-python)
+ $(use_enable python bindings-python)
)
- if ! multilib_is_native_abi; then
- myconf+=(
- --disable-tools
- )
- fi
-
- ECONF_SOURCE="${S}" econf "${myconf[@]}"
+ econf "${myconf[@]}"
}
-multilib_src_install() {
+src_install() {
default
find "${D}" -name '*.la' -type f -delete || die
-
- if ! use static-libs; then
- find "${D}" -name "*.a" -delete || die
- fi
+ find "${D}" -name "*.a" -delete || die
}