summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libmelf/files/libmelf-0.4.0-r1-gcc-makefile-cleanup.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libmelf/files/libmelf-0.4.0-r1-gcc-makefile-cleanup.patch')
-rw-r--r--dev-libs/libmelf/files/libmelf-0.4.0-r1-gcc-makefile-cleanup.patch105
1 files changed, 105 insertions, 0 deletions
diff --git a/dev-libs/libmelf/files/libmelf-0.4.0-r1-gcc-makefile-cleanup.patch b/dev-libs/libmelf/files/libmelf-0.4.0-r1-gcc-makefile-cleanup.patch
new file mode 100644
index 000000000000..384818f57630
--- /dev/null
+++ b/dev-libs/libmelf/files/libmelf-0.4.0-r1-gcc-makefile-cleanup.patch
@@ -0,0 +1,105 @@
+diff -Nuar --exclude '*~' libmelf-0.4.0.orig/example/Makefile.in libmelf-0.4.0/example/Makefile.in
+--- libmelf-0.4.0.orig/example/Makefile.in 2003-03-24 00:48:22.000000000 -0800
++++ libmelf-0.4.0/example/Makefile.in 2010-05-31 19:56:43.546947560 -0700
+@@ -1,7 +1,13 @@
+ cc=@CC@
+ DEFINES=@DEFINES@
++OPTFLAGS=-Wall -O3
++CFLAGS=${DEFINES} ${OPTFLAGS} -I..
++BINS = sign test new
+
+-all:
+- ${CC} ${DEFINES} -I.. -Wall -O3 sign.c -o sign ../libmelf.a
+- ${CC} ${DEFINES} -I.. -Wall -O3 test.c -o test ../libmelf.a
+- ${CC} ${DEFINES} -I.. -Wall -O3 new.c -o new ../libmelf.a
++%: %.c
++ ${CC} $(CFLAGS) $^ -o $@ -L.. -lmelf
++
++all: $(BINS)
++
++clean:
++ -rm -f $(BINS)
+diff -Nuar --exclude '*~' libmelf-0.4.0.orig/Makefile.in libmelf-0.4.0/Makefile.in
+--- libmelf-0.4.0.orig/Makefile.in 2003-11-07 22:09:10.000000000 -0800
++++ libmelf-0.4.0/Makefile.in 2010-05-31 19:58:12.172822406 -0700
+@@ -6,35 +6,43 @@
+ DEFINES=@DEFINES@ -DMELF_COMP
+ INCLUDES=-I.
+ PREFIX=@PREFIX@
+-CFLAGS=${DEBUG} ${DEFINES} ${INCLUDES} -Wall -O3 -fPIC
+-LFLAGS=${DEBUG} ${DEFINES} ${INCLUDES} -Wall -O3 -o
++OPTFLAGS=-Wall -O3
++CFLAGS=${DEBUG} ${DEFINES} ${INCLUDES} ${OPTFLAGS}
++LFLAGS=${DEBUG} ${DEFINES} ${INCLUDES} ${OPTFLAGS} -o
++LIBDIR=lib
+ LIBS=
+ OBJS=melf.o melf_dynamic.o melf_elf.o melf_list.o melf_note.o melf_program.o melf_reloc.o \
+ melf_res.o melf_section.o melf_string.o melf_symbol.o melf_symbolTable.o
+
+-all: ${OBJS}
+- ar rc ${STATICBIN} ${OBJS} && ranlib ${STATICBIN}
+- @SHAREDEXEC@
+- cd example && make
+- cd tools && make
++all: ${STATICBIN} ${DYNAMICBIN}
++ cd example && $(MAKE)
++ cd tools && $(MAKE)
+
+ *.c.${O}:
+ ${CC} ${CFLAGS} $*.c
+
++${STATICBIN}: ${OBJS}
++ ar rc ${STATICBIN} ${OBJS} && ranlib ${STATICBIN}
++${DYNAMICBIN}: ${OBJS}
++ @SHAREDEXEC@
++
+ clean:
+ rm -f *.o ${STATICBIN} ${DYNAMICBIN} example/test example/new example/sign tools/elfres config.*
+- cd tools && make clean
++ cd tools && $(MAKE) clean
+
+-distclean:
+- make clean
++distclean: clean
+ rm -f Makefile example/Makefile stdelf.h
+- cd tools && make distclean
++ cd tools && $(MAKE) distclean
+
+ install: ${OBJS} ${STATICBIN}
+- cp libmelf.a ${PREFIX}/lib
+- cp libmelf.so ${PREFIX}/lib
++ cp ${STATICBIN} ${PREFIX}/$(LIBDIR)
++ cp ${DYNAMICBIN} ${PREFIX}/$(LIBDIR)
+ cp melf.h ${PREFIX}/include
+ cp stdelf.h ${PREFIX}/include
+
+ uninstall:
+- rm -f ${PREFIX}/lib/libmelf.a ${PREFIX}/lib/libmelf.so ${PREFIX}/include/melf.h ${PREFIX}/include/stdelf.h
++ -rm -f \
++ ${PREFIX}/$(LIBDIR)/${STATICBIN} \
++ ${PREFIX}/$(LIBDIR)/${DYNAMICBIN} \
++ ${PREFIX}/include/melf.h \
++ ${PREFIX}/include/stdelf.h
+diff -Nuar --exclude '*~' libmelf-0.4.0.orig/tools/Makefile.in libmelf-0.4.0/tools/Makefile.in
+--- libmelf-0.4.0.orig/tools/Makefile.in 2003-09-17 01:03:49.000000000 -0700
++++ libmelf-0.4.0/tools/Makefile.in 2010-05-31 19:57:55.126198024 -0700
+@@ -1,11 +1,15 @@
+ cc=@CC@
+ DEFINES=@DEFINES@
++CFLAGS=${DEFINES} ${OPTFLAGS} -I..
++BINS=elfres
+
+-all:
+- ${CC} ${DEFINES} -I.. -Wall -O3 elfres.c -o elfres ../libmelf.a
++%: %.c
++ ${CC} $(CFLAGS) $^ -o $@ -L.. -lmelf
++
++all: $(BINS)
+
+ clean:
+- rm -f elfres
++ -rm -f $(BINS)
+
+ distclean:
+- rm -f elfres Makefile
++ -rm -f $(BINS) Makefile