summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-12-04 22:00:23 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2018-12-04 22:20:53 +0000
commitadca6824fd65d3316650ad10183de31f2b7a3c87 (patch)
tree0cffcf60505ac06b0db426a8a15c2eb074e3baeb /dev-libs/libpfm/libpfm-4.10.1.ebuild
parentsci-libs/armadillo: Version bump (diff)
downloadgentoo-adca6824fd65d3316650ad10183de31f2b7a3c87.tar.gz
gentoo-adca6824fd65d3316650ad10183de31f2b7a3c87.tar.bz2
gentoo-adca6824fd65d3316650ad10183de31f2b7a3c87.zip
dev-libs/libpfm: bump up to 4.10.1, bug #666615
Reported-by: Jan Ziak Closes: https://bugs.gentoo.org/666615 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-libs/libpfm/libpfm-4.10.1.ebuild')
-rw-r--r--dev-libs/libpfm/libpfm-4.10.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/libpfm/libpfm-4.10.1.ebuild b/dev-libs/libpfm/libpfm-4.10.1.ebuild
new file mode 100644
index 000000000000..171f7b33de9f
--- /dev/null
+++ b/dev-libs/libpfm/libpfm-4.10.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="Hardware-based performance monitoring interface for Linux"
+HOMEPAGE="http://perfmon2.sourceforge.net"
+SRC_URI="mirror://sourceforge/perfmon2/${PN}4/${P}.tar.gz"
+
+LICENSE="GPL-2 MIT"
+SLOT="0/4"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="static-libs"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -e "s:SLDFLAGS=:SLDFLAGS=\$(LDFLAGS) :g" \
+ -i lib/Makefile || die
+ sed -e "s:LIBDIR=\$(PREFIX)/lib:LIBDIR=\$(PREFIX)/$(get_libdir):g" \
+ -i config.mk || die
+}
+
+src_compile() {
+ # 'DBG=' unsets '-Werror' and other optional flags, bug #664294
+ emake CC=$(tc-getCC) DBG=
+}
+
+src_install() {
+ emake DESTDIR="${D}" LDCONFIG=true PREFIX="${EPREFIX}/usr" install
+ use static-libs || find "${ED}" -name '*.a' -exec rm -f '{}' +
+ dodoc README
+}