summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2019-03-07 21:56:05 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-10 23:45:39 +0100
commit680cf596224596b0691c300b4b27f3551d649c3f (patch)
tree41745cd9c32de539588cb12113cc95f9591f856a /dev-libs/libqtxdg/libqtxdg-3.3.1.ebuild
parentmedia-sound/amsynth: Add USE gtk, lv2 (diff)
downloadgentoo-680cf596224596b0691c300b4b27f3551d649c3f.tar.gz
gentoo-680cf596224596b0691c300b4b27f3551d649c3f.tar.bz2
gentoo-680cf596224596b0691c300b4b27f3551d649c3f.zip
dev-libs/libqtxdg: version bump to 3.3.1
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/11295 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/libqtxdg/libqtxdg-3.3.1.ebuild')
-rw-r--r--dev-libs/libqtxdg/libqtxdg-3.3.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/libqtxdg/libqtxdg-3.3.1.ebuild b/dev-libs/libqtxdg/libqtxdg-3.3.1.ebuild
new file mode 100644
index 000000000000..12c8a7311038
--- /dev/null
+++ b/dev-libs/libqtxdg/libqtxdg-3.3.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils virtualx
+
+DESCRIPTION="A Qt implementation of XDG standards"
+HOMEPAGE="https://lxqt.org/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+ Nokia-Qt-LGPL-Exception-1.1"
+SLOT="0"
+IUSE="test"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5=
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ x11-misc/xdg-utils
+"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qttest:5 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ # Tests don't work with C
+ LC_ALL=en_US.utf8 virtx cmake-utils_src_test
+}