summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2024-09-10 15:18:46 +0200
committerPetr Vaněk <arkamar@gentoo.org>2024-09-10 15:20:11 +0200
commit80b892b0cba5e1695230cd68c79afdfbf3fe102a (patch)
tree6e2dde131a4760600f4db09118d9de441bcb4584 /dev-libs/libucl
parentdev-libs/libucl: drop 0.8.1-r100 (diff)
downloadgentoo-80b892b0cba5e1695230cd68c79afdfbf3fe102a.tar.gz
gentoo-80b892b0cba5e1695230cd68c79afdfbf3fe102a.tar.bz2
gentoo-80b892b0cba5e1695230cd68c79afdfbf3fe102a.zip
dev-libs/libucl: drop 0.9.0
Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'dev-libs/libucl')
-rw-r--r--dev-libs/libucl/Manifest1
-rw-r--r--dev-libs/libucl/files/libucl-0.9.0-gchar-compile.patch36
-rw-r--r--dev-libs/libucl/libucl-0.9.0.ebuild74
3 files changed, 0 insertions, 111 deletions
diff --git a/dev-libs/libucl/Manifest b/dev-libs/libucl/Manifest
index 4444ec1e34e8..fe7b9a6298de 100644
--- a/dev-libs/libucl/Manifest
+++ b/dev-libs/libucl/Manifest
@@ -1,2 +1 @@
-DIST libucl-0.9.0.tar.gz 2043656 BLAKE2B eb2aeb1a818caffbadee9e351d144cc58d149b88e171750e1edfb679c9a42d1c0e8ef2a2dac763445e215370a359791f65364658d3d138e2262a46eba341c0f1 SHA512 a7bcb03dc3b5e3b8e5c141fb3edee0c749e20d63ad69fba4d3c6ca56ef56b1130287b0f497de37bf9789c2263a46121c662fedc7a870354c2849d2e14d90cab5
DIST libucl-0.9.2.tar.gz 2044512 BLAKE2B c0290584517df16ea0e06aa8b5e8c62e8d4f883242a06bec0c385e4d0f5fe8092e076dcb80754963bfca38a9dff62744946096ae16eb547bfc61ffb158951ac4 SHA512 4df54788406baf81c80156cadd938b33aa9a16859981aaa4f82ff447183d87016f647ed22fcdf29fda51b25a58f99f7a1892305aff7c97615f05c125f5966066
diff --git a/dev-libs/libucl/files/libucl-0.9.0-gchar-compile.patch b/dev-libs/libucl/files/libucl-0.9.0-gchar-compile.patch
deleted file mode 100644
index 9ec9105276c1..000000000000
--- a/dev-libs/libucl/files/libucl-0.9.0-gchar-compile.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-Merged as: https://github.com/vstakhov/libucl/commit/708f5e21e3d85f56cdcbcbc418d8725f53bf390b
-From: Vsevolod Stakhov <vsevolod@rspamd.com>
-Date: Tue, 6 Feb 2024 15:59:48 +0000
-Subject: [PATCH] Fix lua compile issues
-
-Issue: #282
---- a/lua/lua_ucl.c
-+++ b/lua/lua_ucl.c
-@@ -406,7 +406,6 @@ ucl_object_lua_fromtable (lua_State *L, int idx, ucl_string_flags_t flags)
-
- /* Table iterate */
- if (is_array) {
-- int i;
-
- if (!is_implicit) {
- top = ucl_object_typed_new (UCL_ARRAY);
-@@ -416,7 +415,7 @@ ucl_object_lua_fromtable (lua_State *L, int idx, ucl_string_flags_t flags)
- top = NULL;
- }
-
-- for (i = 1; i <= max; i ++) {
-+ for (size_t i = 1; i <= max; i ++) {
- lua_pushinteger (L, i);
- lua_gettable (L, idx);
-
-@@ -886,8 +885,8 @@ lua_ucl_parser_parse_text (lua_State *L)
- t = lua_touserdata (L, 2);
- }
- else if (lua_type (L, 2) == LUA_TSTRING) {
-- const gchar *s;
-- gsize len;
-+ const char *s;
-+ size_t len;
- static struct _rspamd_lua_text st_t;
-
- s = lua_tolstring (L, 2, &len);
diff --git a/dev-libs/libucl/libucl-0.9.0.ebuild b/dev-libs/libucl/libucl-0.9.0.ebuild
deleted file mode 100644
index 86d714ebb85a..000000000000
--- a/dev-libs/libucl/libucl-0.9.0.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-{1..3} )
-inherit lua-single autotools
-
-DESCRIPTION="Universal configuration library parser"
-HOMEPAGE="https://github.com/vstakhov/libucl"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/vstakhov/libucl.git"
-else
- SRC_URI="https://github.com/vstakhov/libucl/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="BSD-2"
-SLOT="0/9"
-IUSE="lua +regex sign urls +utils static-libs test"
-REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
-RESTRICT="!test? ( test )"
-
-DEPEND="!!dev-libs/ucl
- lua? ( ${LUA_DEPS} )
- urls? ( net-misc/curl )
- sign? ( dev-libs/openssl:0= )
-"
-BDEPEND="${DEPEND}
- virtual/pkgconfig
-"
-RDEPEND="${DEPEND}"
-
-DOCS=( README.md doc/api.md )
-
-PATCHES=(
- "${FILESDIR}"/${P}-gchar-compile.patch
-)
-
-pkg_setup() {
- use lua && lua-single_pkg_setup
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- "$(use_enable lua)"
- "$(use_enable regex)"
- "$(use_enable sign signatures)"
- "$(use_enable urls)"
- "$(use_enable utils)"
- )
- use lua && myeconfargs+=(
- LUA_INCLUDE="$(lua_get_CFLAGS)"
- LIB_LIBS="$(lua_get_LIBS)"
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- use lua && DOCS+=( "doc/lua_api.md" )
- einstalldocs
- if ! use static-libs; then
- find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || \
- die "error while deleting static library"
- fi
-}