summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-09-29 15:28:07 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-09-29 15:28:07 +0200
commit0ee230b800453fe60225f424f14e717a28a9bdc9 (patch)
tree3bc5131eb3540bd031b0346af8227175897253ed /dev-libs/libuv/libuv-1.44.1.ebuild
parentdev-libs/plasma-wayland-protocols: drop 1.8.0 (diff)
downloadgentoo-0ee230b800453fe60225f424f14e717a28a9bdc9.tar.gz
gentoo-0ee230b800453fe60225f424f14e717a28a9bdc9.tar.bz2
gentoo-0ee230b800453fe60225f424f14e717a28a9bdc9.zip
dev-libs/libuv: drop 1.44.1
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/libuv/libuv-1.44.1.ebuild')
-rw-r--r--dev-libs/libuv/libuv-1.44.1.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/dev-libs/libuv/libuv-1.44.1.ebuild b/dev-libs/libuv/libuv-1.44.1.ebuild
deleted file mode 100644
index b71cb1bbda54..000000000000
--- a/dev-libs/libuv/libuv-1.44.1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools multilib-minimal
-
-DESCRIPTION="Cross-platform asychronous I/O"
-HOMEPAGE="https://github.com/libuv/libuv"
-
-if [[ ${PV} = 9999* ]]; then
- EGIT_REPO_URI="https://github.com/libuv/libuv.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/libuv/libuv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-LICENSE="BSD BSD-2 ISC MIT"
-SLOT="0/1"
-
-BDEPEND="
- sys-devel/libtool
- virtual/pkgconfig
-"
-
-src_prepare() {
- default
-
- echo "m4_define([UV_EXTRA_AUTOMAKE_FLAGS], [serial-tests])" \
- > m4/libuv-extra-automake-flags.m4 || die
-
- if [[ ${CHOST} == *-darwin* && ${CHOST##*darwin} -le 9 ]] ; then
- eapply "${FILESDIR}"/${PN}-1.41.0-darwin.patch
- fi
-
- # upstream fails to ship a configure script
- eautoreconf
-}
-
-multilib_src_configure() {
- local myeconfargs=(
- --disable-static
- cc_cv_cflags__g=no
- )
-
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_test() {
- cp -pPR "${S}"/test/fixtures "${BUILD_DIR}"/test/fixtures || die
- default
-}
-
-multilib_src_install_all() {
- einstalldocs
- find "${ED}" -name '*.la' -delete || die
-}