summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-16 03:17:40 +0100
committerSam James <sam@gentoo.org>2022-04-16 03:17:40 +0100
commit0a1892971ea5601ed670d0364ed7b9156ef5babb (patch)
tree301b13634983a042ff212093a19d78323a69ab49 /dev-libs/mimalloc
parentnet-misc/rsync: fix whitespace (diff)
downloadgentoo-0a1892971ea5601ed670d0364ed7b9156ef5babb.tar.gz
gentoo-0a1892971ea5601ed670d0364ed7b9156ef5babb.tar.bz2
gentoo-0a1892971ea5601ed670d0364ed7b9156ef5babb.zip
dev-libs/mimalloc: add 2.0.6
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/mimalloc')
-rw-r--r--dev-libs/mimalloc/Manifest1
-rw-r--r--dev-libs/mimalloc/mimalloc-2.0.6.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/mimalloc/Manifest b/dev-libs/mimalloc/Manifest
index dbf93f8128c2..b108b0f8f52e 100644
--- a/dev-libs/mimalloc/Manifest
+++ b/dev-libs/mimalloc/Manifest
@@ -1 +1,2 @@
DIST mimalloc-2.0.5.tar.gz 1125567 BLAKE2B 9148ba4af7620eec36e1dde0f6fd2d1e3e9937bd2286ac790a727052402c3286b55387236de3a77e4405983c080bb7acae8deb3334cf9103fcf3f90250080204 SHA512 d164392ace523a3fa0aa00fc58d8a9e8fbe913f07957e19ca977675b389e6d2a2eaf4772e72cae0d87aabb960f3fd6ea3923a066ece4ba4fdaa0c6860cfa414d
+DIST mimalloc-2.0.6.tar.gz 1127052 BLAKE2B bd8a38cc0eab6ad950a63f494f24e6a91c50d2104335e9ce70963a7baadd26c7a2b7440b2fcabe502d9961549222873d017cb525bf5b32da967cf51aa167603c SHA512 f2fc0fbfb6384e85959897f129e5d5d9acc51bda536d5cabcd7d4177dbda9fb735b8a8c239b961f8bea31d37c9ae10f66da23aa91d497f95393253d4ac792bb3
diff --git a/dev-libs/mimalloc/mimalloc-2.0.6.ebuild b/dev-libs/mimalloc/mimalloc-2.0.6.ebuild
new file mode 100644
index 000000000000..2edb208e732f
--- /dev/null
+++ b/dev-libs/mimalloc/mimalloc-2.0.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="A compact general purpose allocator with excellent performance"
+HOMEPAGE="https://github.com/microsoft/mimalloc"
+SRC_URI="https://github.com/microsoft/mimalloc/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ # TODO: build hardened variant?
+ #-DMI_SECURE=$(usex hardened)
+
+ -DMI_INSTALL_TOPLEVEL=ON
+ -DMI_BUILD_TESTS=$(usex test)
+
+ -DMI_BUILD_OBJECT=OFF
+ -DMI_BUILD_STATIC=OFF
+ )
+
+ cmake-multilib_src_configure
+}