summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoss Charles Campbell <rossbridger.cc@gmail.com>2020-08-31 01:33:08 +0800
committerThomas Deutschmann <whissi@gentoo.org>2020-09-01 00:08:56 +0200
commitc7bb7c1750e54218dcf79b622eb6fed17ffa1fa1 (patch)
tree2366d960f804cfe830d4b7887901ebf692ef81c2 /dev-libs/nss
parentdev-libs/nss: Add NS_USE_GCC environment variable (diff)
downloadgentoo-c7bb7c1750e54218dcf79b622eb6fed17ffa1fa1.tar.gz
gentoo-c7bb7c1750e54218dcf79b622eb6fed17ffa1fa1.tar.bz2
gentoo-c7bb7c1750e54218dcf79b622eb6fed17ffa1fa1.zip
dev-libs/nss: detect compiler type and set CC_IS_{GCC,CLANG}
The two flags enables the build system to detect certain compiler features and optimizations. Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Ross Charles Campbell <rossbridger.cc@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/17269 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-libs/nss')
-rw-r--r--dev-libs/nss/nss-3.56.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-libs/nss/nss-3.56.ebuild b/dev-libs/nss/nss-3.56.ebuild
index 1404b61e14ce..c5e3dea3064d 100644
--- a/dev-libs/nss/nss-3.56.ebuild
+++ b/dev-libs/nss/nss-3.56.ebuild
@@ -163,6 +163,12 @@ multilib_src_compile() {
export ASFLAGS=""
# Fix build failure on arm64
export NS_USE_GCC=1
+ # Detect compiler type and set proper environment value
+ if tc-is-gcc; then
+ export CC_IS_GCC=1
+ elif tc-is-clang; then
+ export CC_IS_CLANG=1
+ fi
local d