summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2020-11-12 07:00:00 +0000
committerMike Gilbert <floppym@gentoo.org>2020-11-12 16:54:35 -0500
commit3ac4952dada67205aff293fc8f6d140b47353809 (patch)
tree5ceb947c71446b897b31893766f7ed46905a6ef7 /dev-libs/oniguruma
parentapp-i18n/libkkc: Set maintainer Arfrever. (diff)
downloadgentoo-3ac4952dada67205aff293fc8f6d140b47353809.tar.gz
gentoo-3ac4952dada67205aff293fc8f6d140b47353809.tar.bz2
gentoo-3ac4952dada67205aff293fc8f6d140b47353809.zip
dev-libs/oniguruma: Re-enable POSIX API.
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-libs/oniguruma')
-rw-r--r--dev-libs/oniguruma/oniguruma-6.9.6-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-libs/oniguruma/oniguruma-6.9.6-r1.ebuild b/dev-libs/oniguruma/oniguruma-6.9.6-r1.ebuild
new file mode 100644
index 000000000000..52a40b3d1583
--- /dev/null
+++ b/dev-libs/oniguruma/oniguruma-6.9.6-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2003-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit multilib-minimal
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit autotools git-r3
+
+ EGIT_REPO_URI="https://github.com/kkos/oniguruma"
+fi
+
+DESCRIPTION="Regular expression library for different character encodings"
+HOMEPAGE="https://github.com/kkos/oniguruma"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/kkos/${PN}/releases/download/v${PV}/onig-${PV}.tar.gz"
+fi
+
+LICENSE="BSD-2"
+SLOT="0/5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="crnl-as-line-terminator static-libs"
+
+if [[ "${PV}" != "9999" ]]; then
+ S="${WORKDIR}/onig-${PV}"
+fi
+
+DOCS=(AUTHORS HISTORY README{,_japanese} doc/{API,CALLOUTS.API,CALLOUTS.BUILTIN,FAQ,RE}{,.ja} doc/{SYNTAX.md,UNICODE_PROPERTIES})
+
+src_prepare() {
+ default
+
+ if [[ "${PV}" == "9999" ]]; then
+ eautoreconf
+ fi
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --enable-posix-api \
+ $(use_enable crnl-as-line-terminator) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name "*.la" -delete || die
+}