summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas D <whissi@whissi.de>2016-04-24 02:46:14 +0200
committerSam Jorna <wraeth@gentoo.org>2016-04-24 23:35:50 +1000
commit43107e77a60543c3114befab7f5a723e720a61f5 (patch)
tree04888af754f3fac3d1e088ffecef182300a64fa2 /dev-libs/protobuf-c/protobuf-c-1.2.1-r1.ebuild
parentdev-python/pysrt: bump to 1.1.1 (diff)
downloadgentoo-43107e77a60543c3114befab7f5a723e720a61f5.tar.gz
gentoo-43107e77a60543c3114befab7f5a723e720a61f5.tar.bz2
gentoo-43107e77a60543c3114befab7f5a723e720a61f5.zip
dev-libs/protobuf-c: Slot operator on dev-libs/protobuf atom added wrt bug #580872
Own subslot set to SONAME version. Package-Manager: portage-2.2.28 Signed-off-by: Sam Jorna <wraeth@gentoo.org> Gentoo-bug: 580872 Closes: https://github.com/gentoo/gentoo/pull/1335
Diffstat (limited to 'dev-libs/protobuf-c/protobuf-c-1.2.1-r1.ebuild')
-rw-r--r--dev-libs/protobuf-c/protobuf-c-1.2.1-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/protobuf-c/protobuf-c-1.2.1-r1.ebuild b/dev-libs/protobuf-c/protobuf-c-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..d7439bf8190d
--- /dev/null
+++ b/dev-libs/protobuf-c/protobuf-c-1.2.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools multilib-minimal
+
+MY_PV=${PV/_/-}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="code generator and runtime libraries to use Protocol Buffers (protobuf) from pure C"
+HOMEPAGE="https://github.com/protobuf-c/protobuf-c/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+# Subslot == SONAME version
+SLOT="0/1.0.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static-libs test"
+
+RDEPEND=">=dev-libs/protobuf-2.6.0:0=[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( ${AUTOTOOLS_DEPEND} )
+ virtual/pkgconfig[${MULTILIB_USEDEP}]"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+ if ! use test ; then
+ eapply "${FILESDIR}"/${PN}-1.2.0-no-build-tests.patch
+ eautoreconf
+ fi
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf "${myeconfargs[@]}"
+}