summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-07-06 09:56:27 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-07-06 09:56:27 +0200
commit6f74835c7d6efb9c01186f977c0aaa03e6c74c30 (patch)
tree17665ae49c351b2fc17a159ef09ef4a4669c6ed2 /dev-libs/protobuf-c/protobuf-c-1.3.3.ebuild
parentnet-misc/rsync: SIMD is only available on amd64 + glibc (diff)
downloadgentoo-6f74835c7d6efb9c01186f977c0aaa03e6c74c30.tar.gz
gentoo-6f74835c7d6efb9c01186f977c0aaa03e6c74c30.tar.bz2
gentoo-6f74835c7d6efb9c01186f977c0aaa03e6c74c30.zip
dev-libs/protobuf-c: Bump to version 1.3.3
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/protobuf-c/protobuf-c-1.3.3.ebuild')
-rw-r--r--dev-libs/protobuf-c/protobuf-c-1.3.3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/protobuf-c/protobuf-c-1.3.3.ebuild b/dev-libs/protobuf-c/protobuf-c-1.3.3.ebuild
new file mode 100644
index 000000000000..bc1e64a91cf2
--- /dev/null
+++ b/dev-libs/protobuf-c/protobuf-c-1.3.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+MY_PV="${PV/_/-}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Protocol Buffers implementation in C"
+HOMEPAGE="https://github.com/protobuf-c/protobuf-c"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+# Subslot == SONAME version
+SLOT="0/1.0.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+BDEPEND=">=dev-libs/protobuf-3:0
+ virtual/pkgconfig"
+DEPEND=">=dev-libs/protobuf-3:0=[${MULTILIB_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ if ! use test; then
+ eapply "${FILESDIR}"/${PN}-1.3.0-no-build-tests.patch
+ fi
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}