summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-04-08 15:17:51 -0400
committerCraig Andrews <candrews@gentoo.org>2021-04-08 15:18:16 -0400
commit46cc53d53d30eee0e4a241efb9c640b5aefb4695 (patch)
tree9ce394f5e2c76c9a1db4be181a257c455015d925 /dev-libs/rocr-runtime
parentdev-db/innotop: bump to v1.13.0 (diff)
downloadgentoo-46cc53d53d30eee0e4a241efb9c640b5aefb4695.tar.gz
gentoo-46cc53d53d30eee0e4a241efb9c640b5aefb4695.tar.bz2
gentoo-46cc53d53d30eee0e4a241efb9c640b5aefb4695.zip
dev-libs/rocr-runtime: add debug USE flag
Closes: https://bugs.gentoo.org/780480 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/rocr-runtime')
-rw-r--r--dev-libs/rocr-runtime/rocr-runtime-4.1.0.ebuild6
-rw-r--r--dev-libs/rocr-runtime/rocr-runtime-9999.ebuild12
2 files changed, 15 insertions, 3 deletions
diff --git a/dev-libs/rocr-runtime/rocr-runtime-4.1.0.ebuild b/dev-libs/rocr-runtime/rocr-runtime-4.1.0.ebuild
index 75444f1b60de..caacf00b4bf8 100644
--- a/dev-libs/rocr-runtime/rocr-runtime-4.1.0.ebuild
+++ b/dev-libs/rocr-runtime/rocr-runtime-4.1.0.ebuild
@@ -23,6 +23,7 @@ PATCHES=(
LICENSE="MIT"
SLOT="0/$(ver_cut 1-2)"
+IUSE="debug"
COMMON_DEPEND="sys-process/numactl
dev-libs/elfutils:="
@@ -44,3 +45,8 @@ src_prepare() {
cmake_src_prepare
}
+
+src_configure() {
+ use debug || local mycmakeargs=(-DCMAKE_CXX_FLAGS='-DNDEBUG')
+ cmake_src_configure
+}
diff --git a/dev-libs/rocr-runtime/rocr-runtime-9999.ebuild b/dev-libs/rocr-runtime/rocr-runtime-9999.ebuild
index 2a972d7fd3d0..caacf00b4bf8 100644
--- a/dev-libs/rocr-runtime/rocr-runtime-9999.ebuild
+++ b/dev-libs/rocr-runtime/rocr-runtime-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,11 +18,12 @@ fi
DESCRIPTION="Radeon Open Compute Runtime"
HOMEPAGE="https://github.com/RadeonOpenCompute/ROCR-Runtime"
PATCHES=(
- "${FILESDIR}/${PN}-3.7.0-cmake-install-paths.patch"
+ "${FILESDIR}/${PN}-4.1.0-cmake-install-paths.patch"
)
LICENSE="MIT"
SLOT="0/$(ver_cut 1-2)"
+IUSE="debug"
COMMON_DEPEND="sys-process/numactl
dev-libs/elfutils:="
@@ -40,7 +41,12 @@ src_prepare() {
sed -e "s:find_package(Clang REQUIRED HINTS \${CMAKE_INSTALL_PREFIX}/llvm \${CMAKE_PREFIX_PATH}/llvm PATHS /opt/rocm/llvm ):find_package(Clang REQUIRED HINTS /usr/lib/llvm/roc ):" -i image/blit_src/CMakeLists.txt || die
# Gentoo installs "*.bc" to "/usr/lib" instead of a "[path]/bitcode" directory ...
- sed -e "s:/opt/rocm/amdgcn/bitcode:/usr/lib:" -i image/blit_src/CMakeLists.txt || die
+ sed -e "s:/opt/rocm/amdgcn/bitcode:/usr/lib/amdgcn/bitcode:" -i image/blit_src/CMakeLists.txt || die
cmake_src_prepare
}
+
+src_configure() {
+ use debug || local mycmakeargs=(-DCMAKE_CXX_FLAGS='-DNDEBUG')
+ cmake_src_configure
+}