summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@prydeworx.com>2021-03-11 08:22:07 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-03-27 07:49:55 +0200
commit88ee1aecde5c87b6307271c0cd56786d82c9ecc7 (patch)
tree1d8d481d3293e831c0c17c7381dd02e6a429a00f /dev-libs/s2n/s2n-1.0.0.ebuild
parentdev-libs/aws-c-common: Version Bump to 0.5.2 (diff)
downloadgentoo-88ee1aecde5c87b6307271c0cd56786d82c9ecc7.tar.gz
gentoo-88ee1aecde5c87b6307271c0cd56786d82c9ecc7.tar.bz2
gentoo-88ee1aecde5c87b6307271c0cd56786d82c9ecc7.zip
dev-libs/s2n: Version Bump to 1.0.0 (And fix testing #774276)
This should also fix the failing of s2n_x509_validator_test (#774276) Closes: https://bugs.gentoo.org/774276 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Sven Eden <sven.eden@prydeworx.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/s2n/s2n-1.0.0.ebuild')
-rw-r--r--dev-libs/s2n/s2n-1.0.0.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-libs/s2n/s2n-1.0.0.ebuild b/dev-libs/s2n/s2n-1.0.0.ebuild
new file mode 100644
index 000000000000..e5604e538393
--- /dev/null
+++ b/dev-libs/s2n/s2n-1.0.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Simple, small, fast and secure C99 implementation of the TLS/SSL protocols"
+HOMEPAGE="https://github.com/awslabs/s2n"
+SRC_URI="https://github.com/awslabs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl static-libs test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0=[static-libs=] )
+ libressl? ( dev-libs/libressl:0=[static-libs=] )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.10.21-remove_Werror.patch
+)
+
+S="${WORKDIR}/${PN}-tls-${PV}"
+
+src_prepare() {
+ cmake_src_prepare
+
+ # Fix
+ # QA Notice: The following files contain writable and executable sections (...)
+ sed \
+ -e '$a\\n#if defined(__linux__) && defined(__ELF__)\n.section .note.GNU-stack,"",%progbits\n#endif' \
+ -i "${S}"/pq-crypto/sike_r2/sikep434r2_fp_x64_asm.S || die "sed failed"
+
+ # Fix shared library building, needed for USE="test"
+ # See: https://github.com/awslabs/s2n/issues/2401
+ if use test; then
+ sed -i -e 's, -fvisibility=hidden,,' "${S}"/CMakeLists.txt || die "sed failed"
+ # Remove s2n_self_talk_nonblocking_test, it is broken.
+ # See: https://github.com/awslabs/s2n/issues/2051#issuecomment-744543724
+ rm "${S}"/tests/unit/s2n_self_talk_nonblocking_test.c || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=$(usex !static-libs)
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}