summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2020-12-05 18:06:41 +0300
committerSergey Popov <pinkbyte@gentoo.org>2020-12-05 18:06:57 +0300
commit98f08fcba787f5067b989e3fd373cb35541a3822 (patch)
treec9c13cf0f834f5b71f66c7fd79de440d275d1565 /dev-libs/xmlrpc-c
parentx11-plugins/lurch: Unbundle net-libs/libsignal-protocol-c (diff)
downloadgentoo-98f08fcba787f5067b989e3fd373cb35541a3822.tar.gz
gentoo-98f08fcba787f5067b989e3fd373cb35541a3822.tar.bz2
gentoo-98f08fcba787f5067b989e3fd373cb35541a3822.zip
dev-libs/xmlrpc-c: version bump
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Sergey Popov <pinkbyte@gentoo.org>
Diffstat (limited to 'dev-libs/xmlrpc-c')
-rw-r--r--dev-libs/xmlrpc-c/Manifest1
-rw-r--r--dev-libs/xmlrpc-c/xmlrpc-c-1.51.06.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-libs/xmlrpc-c/Manifest b/dev-libs/xmlrpc-c/Manifest
index 07df7a57ecc4..25d074452ccf 100644
--- a/dev-libs/xmlrpc-c/Manifest
+++ b/dev-libs/xmlrpc-c/Manifest
@@ -1 +1,2 @@
DIST xmlrpc-c-1.39.11.tgz 815463 BLAKE2B 7d169d51835e64e5ac822c48b1a6d7622293c1ce1e7379985ebf6c10f3ab331c55eeff9f655cf914c4cf7e3c107fbdbd741d664489f4ad7aadb5e576ceb383c2 SHA512 13e7ddf5264436671437c0bcd698380baca35c4469f592edf79cb4cafda254fe8207ecb992ee728ed20ec70457a20bd0cf8e180ce5cf0561a38a21f1e588f584
+DIST xmlrpc-c-1.51.06.tgz 933161 BLAKE2B 8023444e14e7e41f5433cebeb0fcb7a7323dd734f658155e117d3547b4d61ef81c189395662bf68074dcf1ec5c47ee550cd18773ce8bf0bd53cb0a1764cce945 SHA512 2927fc8c01d42b6f838d8b0c839f09a7dd0d1ddc5a3d7b36c9d479f1c7bf7fdf14923f640883f98ba66067eda0f5379737bf3a5bc9d4b9abe1a7eff7d7def066
diff --git a/dev-libs/xmlrpc-c/xmlrpc-c-1.51.06.ebuild b/dev-libs/xmlrpc-c/xmlrpc-c-1.51.06.ebuild
new file mode 100644
index 000000000000..18f980a2fffb
--- /dev/null
+++ b/dev-libs/xmlrpc-c/xmlrpc-c-1.51.06.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Upstream maintains 3 release channels: http://xmlrpc-c.sourceforge.net/release.html
+# 1. Only the "Super Stable" series is released as a tarball
+# 2. SVN tagging of releases seems spotty: http://svn.code.sf.net/p/xmlrpc-c/code/release_number/
+# Because of this, we are following the "Super Stable" release channel
+
+DESCRIPTION="A lightweigt RPC library based on XML and HTTP"
+HOMEPAGE="http://xmlrpc-c.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="abyss +cgi +curl +cxx +libxml2 threads test"
+
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="test? ( abyss curl cxx )"
+
+RDEPEND="
+ sys-libs/ncurses:0=
+ sys-libs/readline:0=
+ curl? ( net-misc/curl )
+ libxml2? ( dev-libs/libxml2 )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ use curl || ewarn "Curl support disabled: No client library will be built"
+}
+
+src_prepare() {
+ sed -i \
+ -e "/CFLAGS_COMMON/s|-g -O3$||" \
+ -e "/CXXFLAGS_COMMON/s|-g$||" \
+ common.mk || die
+
+ default
+}
+
+src_configure() {
+ econf \
+ --disable-libwww-client \
+ --disable-wininet-client \
+ --without-libwww-ssl \
+ $(use_enable abyss abyss-server) \
+ $(use_enable cgi cgi-server) \
+ $(use_enable curl curl-client) \
+ $(use_enable cxx cplusplus) \
+ $(use_enable libxml2 libxml2-backend) \
+ $(use_enable threads abyss-threads)
+}
+
+src_compile() {
+ default
+ # Tools building is broken in this release
+ #use tools && emake -rC "${S}"/tools
+}
+
+src_install() {
+ default
+ # Tools building is broken in this release
+ #use tools && emake DESTDIR="${D}" -rC "${S}"/tools install
+}