summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2019-05-07 08:59:49 +0200
committerGuilherme Amadio <amadio@gentoo.org>2019-05-07 08:59:49 +0200
commit466a92ce3a5368722c93b01e35511d7a16b56a54 (patch)
treed9bd4aed37a24d576dd674921544b6ae57556a22 /dev-libs/xxhash/xxhash-0.7.0.ebuild
parentsci-physics/root: update dependencies for afterstep removal (diff)
downloadgentoo-466a92ce3a5368722c93b01e35511d7a16b56a54.tar.gz
gentoo-466a92ce3a5368722c93b01e35511d7a16b56a54.tar.bz2
gentoo-466a92ce3a5368722c93b01e35511d7a16b56a54.zip
dev-libs/xxhash: bump version to 0.7.0
Closes: https://bugs.gentoo.org/684136 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'dev-libs/xxhash/xxhash-0.7.0.ebuild')
-rw-r--r--dev-libs/xxhash/xxhash-0.7.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/xxhash/xxhash-0.7.0.ebuild b/dev-libs/xxhash/xxhash-0.7.0.ebuild
new file mode 100644
index 000000000000..382d4b60dd12
--- /dev/null
+++ b/dev-libs/xxhash/xxhash-0.7.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Extremely fast non-cryptographic hash algorithm"
+HOMEPAGE="http://www.xxhash.com"
+SRC_URI="https://github.com/Cyan4973/xxHash/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x64-macos"
+IUSE="static-libs"
+
+S="${WORKDIR}/xxHash-${PV}"
+
+src_compile() {
+ PREFIX="${EPREFIX}/usr" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)"
+}
+
+src_install() {
+ PREFIX="${EPREFIX}/usr" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ MANDIR="${EPREFIX}/usr/share/man/man1" \
+ emake DESTDIR="${D}" install
+
+ if ! use static-libs ; then
+ rm "${ED}"/usr/$(get_libdir)/libxxhash.a || die
+ fi
+}