summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-12-09 15:23:55 -0500
committerAaron Bauman <bman@gentoo.org>2019-12-09 15:29:29 -0500
commit5c296ba0e6f890213b01ccd4883e8dcf90cbb8e5 (patch)
treed75bfbe7c3052d0bc7410c198d158215d62f7b17 /dev-libs
parentsys-*/*: drop last-rited pkgs (diff)
downloadgentoo-5c296ba0e6f890213b01ccd4883e8dcf90cbb8e5.tar.gz
gentoo-5c296ba0e6f890213b01ccd4883e8dcf90cbb8e5.tar.bz2
gentoo-5c296ba0e6f890213b01ccd4883e8dcf90cbb8e5.zip
dev-libs/cygwin: drop last-rited pkg
Closes: https://bugs.gentoo.org/697344 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/cygwin/Manifest3
-rw-r--r--dev-libs/cygwin/cygwin-1.5.25.15.ebuild92
-rw-r--r--dev-libs/cygwin/metadata.xml8
3 files changed, 0 insertions, 103 deletions
diff --git a/dev-libs/cygwin/Manifest b/dev-libs/cygwin/Manifest
deleted file mode 100644
index 21b6496e84b8..000000000000
--- a/dev-libs/cygwin/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST cygwin-1.5.25-15-src.tar.bz2 11486150 BLAKE2B 0fb9119396fc609dc243026a1a706a2a9ff87d34184581802d284a138e575dedce62f176cf31b02ab1bd9c1e218588b4f35e4a72cc554c95fc84af1f5f5bb47a SHA512 464553b06f74ffad464361b0bddb2eacc581abfb68f2154bba8f70334274ec63901b1f46f73cf930b05256467196e1b1ab8003215bb12ea6a42ad73fd9ac229a
-DIST cygwin-1.5.25-15.tar.bz2 1427096 BLAKE2B 7a6a2a5be6eaec21660a8f4ffa3e76f5390f9893a057d2d22ff888989c2fa11137b5516d7dd9698c17a92f5296a11d2c0c5ad8f594196ee29232508d29e10641 SHA512 72f677cd9140d4f61808203a56234e47b8e3a6e18438ff2c8d47d45472d6cc671e4dc42603967e62a1b2293d4bd9d4e1d95652746f939a6d5e1f1ec2f6c96105
-DIST w32api-3.12-1.tar.bz2 1229076 BLAKE2B 1e182fc23c01fa58fb63510351a9aa76aa046dc4971a9cdf402be0100c8765323afbd207a5ba9a92e8f906bcedbbcbf1888685092554bab0238066d490009dee SHA512 739f1f71163cac83ed892dda157f25bb30e70f2c1b134df069a6ece5fb5784e4394d597b078a8a913b8b66fb0f617495aeb94ceab2f1e5a25dab712a010f3f29
diff --git a/dev-libs/cygwin/cygwin-1.5.25.15.ebuild b/dev-libs/cygwin/cygwin-1.5.25.15.ebuild
deleted file mode 100644
index 433361029fd4..000000000000
--- a/dev-libs/cygwin/cygwin-1.5.25.15.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit flag-o-matic toolchain-funcs
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
- fi
-fi
-
-W32API_BIN="3.12-1"
-MY_P="${PN}-${PV%.*}-${PV##*.}"
-DESCRIPTION="Linux-like environment for Windows"
-HOMEPAGE="http://cygwin.com/"
-SRC_URI="!headers-only? ( ftp://sourceware.org/pub/cygwin/release/cygwin/${MY_P}-src.tar.bz2 )
- headers-only? (
- ftp://sourceware.org/pub/cygwin/release/w32api/w32api-${W32API_BIN}.tar.bz2
- ftp://sourceware.org/pub/cygwin/release/cygwin/${MY_P}.tar.bz2
- )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="headers-only"
-RESTRICT="strip"
-
-DEPEND=""
-
-S=${WORKDIR}
-
-just_headers() {
- use headers-only && [[ ${CHOST} != ${CTARGET} ]]
-}
-
-pkg_setup() {
- if [[ ${CBUILD} == ${CHOST} ]] && [[ ${CHOST} == ${CTARGET} ]] ; then
- die "Invalid configuration; do not emerge this directly"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- if just_headers ; then
- mv usr/lib/w32api/* usr/lib/ || die
- else
- rm -rf ${MY_P}/etc # scrub garbage
- fi
-}
-
-src_compile() {
- if just_headers ; then
- return 0
-
- # steps to install via src pkg
- cd winsup/cygwin
- econf || die
- else
- CHOST=${CTARGET} strip-unsupported-flags
- mkdir "${WORKDIR}"/build
- cd "${WORKDIR}"/build
- ECONF_SOURCE=${S} \
- econf --prefix=/usr/${CTARGET}/usr || die
- emake || die
- fi
-}
-
-src_install() {
- if just_headers ; then
- # cygwin guys do not support bootstrapping. thus the cygwin src pkg
- # blows and cannot be bootstrapped. use the binaries -- the only
- # thing upstream supports.
- insinto /usr/${CTARGET}
- doins -r * || die
- return 0
-
- # steps to install via src pkg
- insinto /usr/${CTARGET}/usr/include
- doins -r winsup/w32api/include/* || die
- doins -r newlib/libc/include/* || die
- dosym usr/include /usr/${CTARGET}/sys-include
- cd winsup/cygwin
- emake install-headers tooldir="${D}"/usr/${CTARGET}/usr || die
- else
- cd "${WORKDIR}"/build
- emake install DESTDIR="${D}" || die
- fi
-}
diff --git a/dev-libs/cygwin/metadata.xml b/dev-libs/cygwin/metadata.xml
deleted file mode 100644
index e396f3755977..000000000000
--- a/dev-libs/cygwin/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>toolchain@gentoo.org</email>
- <name>Gentoo Toolchain Project</name>
-</maintainer>
-</pkgmetadata>