summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-05-03 10:06:07 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-05-03 10:07:57 +0300
commit6d8162c3e6bf66134462660f68d692019dacc778 (patch)
tree92665bac09d8531054a22db3818d26257b041aea /dev-libs
parentdev-python/agate: add 1.10.2 (diff)
downloadgentoo-6d8162c3e6bf66134462660f68d692019dacc778.tar.gz
gentoo-6d8162c3e6bf66134462660f68d692019dacc778.tar.bz2
gentoo-6d8162c3e6bf66134462660f68d692019dacc778.zip
dev-libs/cjose: add 0.6.2.3
Closes: https://bugs.gentoo.org/922461 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/cjose/Manifest1
-rw-r--r--dev-libs/cjose/cjose-0.6.2.3.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/cjose/Manifest b/dev-libs/cjose/Manifest
index 4fa7b26db7a8..1365f12734f1 100644
--- a/dev-libs/cjose/Manifest
+++ b/dev-libs/cjose/Manifest
@@ -1 +1,2 @@
DIST cjose-0.6.2.2.tar.gz 498461 BLAKE2B 4914019652f47ac12745cb3b8914f66cb41cb8da33f83735d866cac816dd8f6475d12fde4a6e3f58456c463cb7c6c6fdfeb4928c232f94e3fa6b1b4c8e5ef132 SHA512 71a087709816f0aac060a7c5f037068e981366b1809f6ee32e39eaded02ad8be061b0e2fa5093515a8acec10c7f4aca232281004426221b4b7e5edbd203eb49c
+DIST cjose-0.6.2.3.tar.gz 500613 BLAKE2B cf5f7f7bcb3e7cfa643a9f9f0e88498874a78cd8799be961a5c1c1ac03f24ef75ec8b0624a7ec4ffa8f9ebedda0e4c35fb0dc72547620b63ada5e719dfe2f778 SHA512 193434afef21fc4889902896d984bf57c64240346de27be94c229491d43e1d309bbb11905be4899fc7f3c1885323ee9480bf30499f37f3174ab9a1e282f5841f
diff --git a/dev-libs/cjose/cjose-0.6.2.3.ebuild b/dev-libs/cjose/cjose-0.6.2.3.ebuild
new file mode 100644
index 000000000000..e4fd2351b19d
--- /dev/null
+++ b/dev-libs/cjose/cjose-0.6.2.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="C library implementing the Javascript Object Signing and Encryption (JOSE)"
+HOMEPAGE="https://github.com/OpenIDC/cjose"
+
+SRC_URI="https://github.com/OpenIDC/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-libs/jansson-2.11:=
+ >=dev-libs/openssl-1.0.2u:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( >=app-text/doxygen-1.8 )
+ test? ( >=dev-libs/check-0.9.4 )"
+
+src_prepare() {
+ default
+
+ # Remove -Werror from the build, bug #922461
+ sed -e 's/ -Werror//' -i src/Makefile.{am,in} || die
+
+ eautoreconf --force --install
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}