summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-10 17:14:20 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-10 20:20:23 +0100
commit82ae39d1cd624bfb0ca3e480dbdfff8e82f2e152 (patch)
tree159e4ce6772748a7e6afd1803e8cf616a5b547de /dev-libs
parentsys-libs/libomp: Unpin rocr-runtime dep (diff)
downloadgentoo-82ae39d1cd624bfb0ca3e480dbdfff8e82f2e152.tar.gz
gentoo-82ae39d1cd624bfb0ca3e480dbdfff8e82f2e152.tar.bz2
gentoo-82ae39d1cd624bfb0ca3e480dbdfff8e82f2e152.zip
dev-libs/libclc: Remove 17.0.0_pre20230225
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libclc/Manifest1
-rw-r--r--dev-libs/libclc/libclc-17.0.0_pre20230225.ebuild88
2 files changed, 0 insertions, 89 deletions
diff --git a/dev-libs/libclc/Manifest b/dev-libs/libclc/Manifest
index 1edea9832f73..b055e2dfd698 100644
--- a/dev-libs/libclc/Manifest
+++ b/dev-libs/libclc/Manifest
@@ -5,4 +5,3 @@ DIST llvm-project-15.0.7.src.tar.xz.sig 566 BLAKE2B 47dc8c82d86237b80c6d85f83a6c
DIST llvm-project-16.0.0rc3.src.tar.xz 117914548 BLAKE2B 18ffa35eb73c7cc4626d7b6b7b30aade7171ee2e17fb8d72e79a67185e809f611fefa4cfef17e5cd16822a5a70de2222534dc9f146fc53987eb49ff6a9d98c18 SHA512 d14e5e5ec984a0dc0292a2d27440398b3e32f120c1579517054dcb1a05dbc4ac5f1c6d078a3d6ef8597a71af6f22863868680a972a571839dcd573418b4a4697
DIST llvm-project-16.0.0rc3.src.tar.xz.sig 566 BLAKE2B 43683d2d7b266a847516f71412bf6236a355462430330fc0da1d624fb8dfbc98bfc982d367baee74d5b4964a9e82e7a4a6ea84bdcff3996d246932f516cced1a SHA512 61adc4dc3eb5a4c11a7f96f9267ff37895e5845a08d48a609a03a2696c1b6bca5af5861a6f28de936c48e6d621bf282170589187f2cb593a912b9078300cf47c
DIST llvm-project-2708869801ae00f4681f6b2d9d69b25b3fce26b6.tar.gz 180523586 BLAKE2B cf918d1e23f922d201a44531c9765b7d8ec2b3b8499ea7954845abcd5fa2687e85b3a34819a583c4f4a6d6e1baa49dbac0b4450cd6b9b322b0f13c88cd7da93c SHA512 18cb00e93d819993a925ae0467d382bc952d82c1eb92dbbb5bb3cdf87043269948670713734ddc3ea4ec50544e54dd11b6747496f7eaa02479374ab9ad075aa5
-DIST llvm-project-b0676fb0fb0a44a4a1c4ec1f0270fef1f1842817.tar.gz 180277698 BLAKE2B d2c1e6a1942e51f5844c18605f38b005e9bb4123850a173e4c4b3d7b6a14f4986c7b276b40df4d0594ae04e869e92ba1a4269c5055c0229cfd28aa1bd709da4f SHA512 d1281b942dcc254641865f11b0c4fbd1d562d016681b6b7268549bed1cdb7d4536f743a8ed089095eaab9f4bfb9de624153f448bf13d0e22f8ea24a4d264df7b
diff --git a/dev-libs/libclc/libclc-17.0.0_pre20230225.ebuild b/dev-libs/libclc/libclc-17.0.0_pre20230225.ebuild
deleted file mode 100644
index 93cce600989e..000000000000
--- a/dev-libs/libclc/libclc-17.0.0_pre20230225.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-inherit cmake llvm llvm.org python-any-r1
-
-DESCRIPTION="OpenCL C library"
-HOMEPAGE="https://libclc.llvm.org/"
-
-LICENSE="Apache-2.0-with-LLVM-exceptions || ( MIT BSD )"
-SLOT="0"
-KEYWORDS=""
-IUSE="spirv video_cards_nvidia video_cards_r600 video_cards_radeonsi"
-
-LLVM_MAX_SLOT=17
-BDEPEND="
- ${PYTHON_DEPS}
- || (
- (
- sys-devel/clang:17
- spirv? ( dev-util/spirv-llvm-translator:17 )
- )
- (
- sys-devel/clang:16
- spirv? ( dev-util/spirv-llvm-translator:16 )
- )
- (
- sys-devel/clang:15
- spirv? ( dev-util/spirv-llvm-translator:15 )
- )
- (
- sys-devel/clang:14
- spirv? ( dev-util/spirv-llvm-translator:14 )
- )
- (
- sys-devel/clang:13
- spirv? ( dev-util/spirv-llvm-translator:13 )
- )
- )
-"
-
-LLVM_COMPONENTS=( libclc )
-llvm.org_set_globals
-
-llvm_check_deps() {
- if use spirv; then
- has_version -b "dev-util/spirv-llvm-translator:${LLVM_SLOT}" ||
- return 1
- fi
- has_version -b "sys-devel/clang:${LLVM_SLOT}"
-}
-
-pkg_setup() {
- llvm_pkg_setup
- python-any-r1_pkg_setup
-}
-
-src_configure() {
- local libclc_targets=()
-
- use spirv && libclc_targets+=(
- "spirv-mesa3d-"
- "spirv64-mesa3d-"
- )
- use video_cards_nvidia && libclc_targets+=(
- "nvptx--"
- "nvptx64--"
- "nvptx--nvidiacl"
- "nvptx64--nvidiacl"
- )
- use video_cards_r600 && libclc_targets+=(
- "r600--"
- )
- use video_cards_radeonsi && libclc_targets+=(
- "amdgcn--"
- "amdgcn-mesa-mesa3d"
- "amdgcn--amdhsa"
- )
- [[ ${#libclc_targets[@]} ]] || die "libclc target missing!"
-
- libclc_targets=${libclc_targets[*]}
- local mycmakeargs=(
- -DLIBCLC_TARGETS_TO_BUILD="${libclc_targets// /;}"
- )
- cmake_src_configure
-}