summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-11-30 13:29:30 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-11-30 14:32:53 +0100
commitb41f80eaebe323f6dec04b2b391f529986c7f7dd (patch)
treea46352267612441c3e245ea4c7be4077ea06d1ac /dev-lua/inifile
parentdev-lua/luassert: remove lua deps version requirement (diff)
downloadgentoo-b41f80eaebe323f6dec04b2b391f529986c7f7dd.tar.gz
gentoo-b41f80eaebe323f6dec04b2b391f529986c7f7dd.tar.bz2
gentoo-b41f80eaebe323f6dec04b2b391f529986c7f7dd.zip
dev-lua/inifile: new package
This is a simple ini parser for lua. It will serve as da lua dep for packages, which will get added tests and need that. Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/inifile')
-rw-r--r--dev-lua/inifile/Manifest1
-rw-r--r--dev-lua/inifile/inifile-1.0-r100.ebuild30
-rw-r--r--dev-lua/inifile/inifile-1.0.ebuild30
-rw-r--r--dev-lua/inifile/metadata.xml11
4 files changed, 72 insertions, 0 deletions
diff --git a/dev-lua/inifile/Manifest b/dev-lua/inifile/Manifest
new file mode 100644
index 000000000000..e14e8c979c70
--- /dev/null
+++ b/dev-lua/inifile/Manifest
@@ -0,0 +1 @@
+DIST inifile-1.0.tar.gz 2611 BLAKE2B cdda6d9b2de45b4bec4695029018e37fe22a993afe5a54df4f4c519457d00267338de5aa3379a72dc7ab962260cd39f49674c2685799e4ad5544fed938c1080b SHA512 d0a9aa825cd5cf4a3b0b562853f3593141f537388c3e3a4334317b2536aa2dd695bdea37058d3d907aad10162bb71ef5b324c769e65cbd18e4526e37275cb970
diff --git a/dev-lua/inifile/inifile-1.0-r100.ebuild b/dev-lua/inifile/inifile-1.0-r100.ebuild
new file mode 100644
index 000000000000..89a8791ca127
--- /dev/null
+++ b/dev-lua/inifile/inifile-1.0-r100.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..3} luajit )
+MY_PV="${PV/_p/-}"
+
+inherit lua
+
+DESCRIPTION="A simple and complete ini parser for Lua"
+HOMEPAGE="https://github.com/bartbes/inifile/"
+SRC_URI="https://github.com/bartbes/inifile/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="${LUA_DEPS}"
+BDEPEND="virtual/pkgconfig"
+
+lua_src_install() {
+ insinto $(lua_get_lmod_dir)
+ doins inifile.lua
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+}
diff --git a/dev-lua/inifile/inifile-1.0.ebuild b/dev-lua/inifile/inifile-1.0.ebuild
new file mode 100644
index 000000000000..05056d9afbd7
--- /dev/null
+++ b/dev-lua/inifile/inifile-1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV="${PV/_p/-}"
+
+inherit toolchain-funcs
+
+DESCRIPTION="A simple and complete ini parser for Lua"
+HOMEPAGE="https://github.com/bartbes/inifile/"
+SRC_URI="https://github.com/bartbes/inifile/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="luajit"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="
+ luajit? ( dev-lang/luajit:2 )
+ !luajit? ( >=dev-lang/lua-5.1:= )
+"
+
+BDEPEND="virtual/pkgconfig"
+
+src_install() {
+ insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD $(usex luajit 'luajit' 'lua'))"
+ doins inifile.lua
+}
diff --git a/dev-lua/inifile/metadata.xml b/dev-lua/inifile/metadata.xml
new file mode 100644
index 000000000000..9da69fdb9869
--- /dev/null
+++ b/dev-lua/inifile/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">bartbes/inifile</remote-id>
+ </upstream>
+</pkgmetadata>