summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-04-17 13:56:07 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-04-17 16:11:28 +0200
commit9874b10129c95017c66aad31412494951fbe08fb (patch)
treed53b91fcdf426997a9bc575a7977410f49dcaab5 /dev-lua
parentx11-misc/dunst: add 1.11.0 (diff)
downloadgentoo-9874b10129c95017c66aad31412494951fbe08fb.tar.gz
gentoo-9874b10129c95017c66aad31412494951fbe08fb.tar.bz2
gentoo-9874b10129c95017c66aad31412494951fbe08fb.zip
dev-lua/penlight: add 1.14.0
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/penlight/Manifest1
-rw-r--r--dev-lua/penlight/penlight-1.14.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-lua/penlight/Manifest b/dev-lua/penlight/Manifest
index 3c2a99bd868a..c2a03d6ea6f3 100644
--- a/dev-lua/penlight/Manifest
+++ b/dev-lua/penlight/Manifest
@@ -1 +1,2 @@
DIST penlight-1.13.1.tar.gz 434059 BLAKE2B 09a509afc11ad28b88fc92e9f9237fef4d18fc4c5b8c401c6fc8b4e3765941534409e5e5c9c9a08e0ad1a8b08d635d9ef8b453ec602514e4365317e1b31bbf63 SHA512 de0a6a2f585f32bed234ef084d8fca9cee645eed3459aa3c39b885b46a05ae752b5c7ac3bb1957fef9519df2a11e250fc87d6d4d62ee6155be2742ad43a079fe
+DIST penlight-1.14.0.tar.gz 439720 BLAKE2B 22ba9741dfcc446c2ffaa38af26f2a5b5022e316c63acc552ad4b7158c97e9239bdf124f1dc3438bd272f8dc79d8ae090f1aa7ba4b3bbcd5d006ec7244fc4041 SHA512 a83f70716106d6576b27a42222ba897d5d5a7b3918088c582e89283cf091a95a9920fe6d0b8d65e1ffc4c1664166f7d5bc4df3b023539d1b33d7175e585bbe9f
diff --git a/dev-lua/penlight/penlight-1.14.0.ebuild b/dev-lua/penlight/penlight-1.14.0.ebuild
new file mode 100644
index 000000000000..9dc40907ae10
--- /dev/null
+++ b/dev-lua/penlight/penlight-1.14.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+MY_PN="Penlight"
+
+inherit lua
+
+DESCRIPTION="Lua utility libraries loosely based on the Python standard libraries"
+HOMEPAGE="https://github.com/lunarmodules/Penlight"
+SRC_URI="https://github.com/lunarmodules/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+DEPEND="${LUA_DEPS}"
+
+RDEPEND="
+ dev-lua/luafilesystem[${LUA_USEDEP}]
+ ${DEPEND}
+"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? ( ${DEPEND} )
+"
+
+HTML_DOCS=( "docs/." )
+
+src_prepare() {
+ default
+
+ # This is a demo app, not a real test
+ rm tests/test-app.lua || die
+
+ # Remove test for executing a non-existent command
+ sed -e '/most-likely-nonexistent-command/d' -i tests/test-utils3.lua || die
+}
+
+lua_src_test() {
+ "${ELUA}" run.lua || die
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ insinto $(lua_get_lmod_dir)
+ doins -r lua/pl
+
+ einstalldocs
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+}