summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-01-21 23:05:01 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-01-21 23:05:01 +0100
commit04567015f131419f60a5c5e4afa21fadb788e4d0 (patch)
tree3103b062c2a72dc13b5e0186f691200f4667ac91 /dev-ml/labltk/labltk-8.06.7.ebuild
parentapp-emacs/racket-mode: require non-minimal racket (diff)
downloadgentoo-04567015f131419f60a5c5e4afa21fadb788e4d0.tar.gz
gentoo-04567015f131419f60a5c5e4afa21fadb788e4d0.tar.bz2
gentoo-04567015f131419f60a5c5e4afa21fadb788e4d0.zip
dev-ml/labltk: do not call ranlib directly
Closes: https://bugs.gentoo.org/727250 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/labltk/labltk-8.06.7.ebuild')
-rw-r--r--dev-ml/labltk/labltk-8.06.7.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/dev-ml/labltk/labltk-8.06.7.ebuild b/dev-ml/labltk/labltk-8.06.7.ebuild
index 193ef043c201..e10d95339561 100644
--- a/dev-ml/labltk/labltk-8.06.7.ebuild
+++ b/dev-ml/labltk/labltk-8.06.7.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit findlib
+inherit findlib toolchain-funcs
DESCRIPTION="OCaml interface to the Tcl/Tk GUI framework"
HOMEPAGE="https://garrigue.github.io/labltk/"
@@ -15,6 +15,7 @@ KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 x86 ~amd64-linux ~x
IUSE="+ocamlopt X"
RDEPEND=">=dev-lang/tk-8.0.3:=
+ <dev-lang/ocaml-4.10
>=dev-lang/ocaml-4.08:=[ocamlopt?,X(+)?]"
DEPEND="${RDEPEND}
>=dev-ml/findlib-1.5.5-r1"
@@ -23,6 +24,14 @@ PATCHES=(
"${FILESDIR}/findlib.patch"
)
+src_prepare() {
+ sed -i \
+ -e "s|ranlib|$(tc-getRANLIB)|" \
+ frx/Makefile \
+ || die
+ default
+}
+
src_configure() {
./configure --use-findlib --verbose $(usex X "--tk-x11" "--tk-no-x11") || die "configure failed!"
}