summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-08-27 14:39:55 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-08-27 14:42:47 +0200
commit0834efea40c25bdae2e66b5ca0ed5ca7fe07a2f2 (patch)
tree5f2e275f1053cf82d0ffc2b6df0b5ed73ce5a6fe /dev-ml/merlin
parentdev-ml/reason: drop old 3.8.2 (diff)
downloadgentoo-0834efea40c25bdae2e66b5ca0ed5ca7fe07a2f2.tar.gz
gentoo-0834efea40c25bdae2e66b5ca0ed5ca7fe07a2f2.tar.bz2
gentoo-0834efea40c25bdae2e66b5ca0ed5ca7fe07a2f2.zip
dev-ml/merlin: bump to 4.10
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml/merlin')
-rw-r--r--dev-ml/merlin/Manifest1
-rw-r--r--dev-ml/merlin/merlin-4.10.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/dev-ml/merlin/Manifest b/dev-ml/merlin/Manifest
index 44e3b33147cf..0daf01decf3a 100644
--- a/dev-ml/merlin/Manifest
+++ b/dev-ml/merlin/Manifest
@@ -1,3 +1,4 @@
+DIST merlin-4.10-414.tbz 1989927 BLAKE2B 9a65e9c1a2d5795e1e0235d5c8b0274bd9d8ef052ed421e8809224de73f577da273c9f1ca0f071d6ea0accd349b9b6d59b2e1fb5561effe483ebb0de89a4c766 SHA512 7805b99c2a73b2e3f70d26fd7183a90f97657d66946e2a4b58563f00fd3ed8d82da1fb0597b033b8c8c9e8db415d66e51720c972d34db4b66b71bb8f0c9ee08c
DIST merlin-4.5-411.tbz 1316537 BLAKE2B 8850ea6b15819a178f763d8b55fecca9104cec5097c39afad7dc8b59543d961d7aa4a86590ebb59a3066d1f6630f11284e24835398ab967f45a52faf004477f1 SHA512 9e68ebabdc0cc398edcd255516070d6459f3bf5738c0dbe332c11c6bc4070e7bf340bc086fa2ea58597972ebe9d15860ecd0e549444809be809f0509b41652c2
DIST merlin-4.5-412.tbz 1765436 BLAKE2B eaed065a2814f4c1bfc5337d026c7c42287b8cbbe50097415a983f7fdd7323f4c88f3b8c8cff4ca88a0813204617f39807709a6703fd618269eca6063b3c47b1 SHA512 f9edc3e1c9f753d7bacbdf1b92c118b54f9e9eff0bf752a2b44f39a2f7ecc76c4cd3bbe9227e910aea8b5ea947e8fe1b8d92ba0245fe47bc8cc2f45404cca973
DIST merlin-4.5-413.tbz 2290507 BLAKE2B 32aeda63caec645da8043c49ceaa0ea54d095b3e286f687b5f3da1b44d54bbc291d0358768d2180825cb620a91765da83d90b645151a694a4131788ab4438fbf SHA512 b1db98c38a97ca0eef3051ab2b5d1b158e757863de6908a830308e7ea7f960eebd64b1a60bf51b10b7ea2eea3141ee0917a7c3570b63f9faa2e3f69c5d6fe0c2
diff --git a/dev-ml/merlin/merlin-4.10.ebuild b/dev-ml/merlin/merlin-4.10.ebuild
new file mode 100644
index 000000000000..3e4435149b42
--- /dev/null
+++ b/dev-ml/merlin/merlin-4.10.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# TODO: vim-plugin, although it's not clear how to make it work here
+inherit elisp-common dune
+
+DESCRIPTION="Context sensitive completion for OCaml in Vim and Emacs"
+HOMEPAGE="https://github.com/ocaml/merlin/"
+SRC_URI="https://github.com/ocaml/merlin/releases/download/v${PV}-414/${P}-414.tbz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="emacs +ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-lang/ocaml:=[ocamlopt?]
+ dev-ml/csexp:=
+ >=dev-ml/yojson-2.0.0:=
+ dev-ml/menhir:=
+ >=dev-ml/dune-2.9:=
+ || (
+ dev-lang/ocaml:0/4.14
+ dev-lang/ocaml:0/4.14.1
+ )
+ emacs? (
+ >=app-editors/emacs-23.1:*
+ app-emacs/auto-complete
+ app-emacs/company-mode
+ )
+"
+DEPEND="${RDEPEND}"
+# NOTICE: Block dev-ml/seq (which is a back-port of code to ocaml <4.07)
+# because it breaks merlin builds.
+# https://github.com/ocaml/merlin/issues/1500
+BDEPEND="
+ !!<dev-ml/seq-0.3
+ test? ( app-misc/jq )
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_unpack() {
+ default
+
+ if has_version "dev-lang/ocaml:0/4.14" ; then
+ mv ${P}-414 "${S}" || die
+ elif has_version "dev-lang/ocaml:0/4.14.1" ; then
+ mv ${P}-414 "${S}" || die
+ fi
+}
+
+src_prepare() {
+ default
+
+ # Handle ELisp installation via the Emacs Eclass.
+ rm emacs/dune || die
+
+ # This test runs only inside a git repo,
+ # it is not included in merlin release for ocaml 4.12.
+ if [[ -f tests/test-dirs/occurrences/issue1404.t ]] ; then
+ rm tests/test-dirs/occurrences/issue1404.t || die
+ fi
+ rm -r tests/test-dirs/locate/context-detection/cd-mod_constr.t || die
+
+ # Remove seq references from dune build files.
+ sed -i 's|seq||g' src/frontend/ocamlmerlin/dune || die
+}
+
+src_compile() {
+ edune build @install
+
+ if use emacs ; then
+ # iedit isn't packaged yet
+ rm emacs/merlin-iedit.el || die
+
+ BYTECOMPFLAGS="-L emacs" elisp-compile emacs/*.el
+ fi
+}
+
+src_install() {
+ dune_src_install
+
+ if use emacs ; then
+ elisp-install ${PN} emacs/*.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}